summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:25 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:58 +0000
commit991a289a023c1f466564c5a878f98d7f3ae6a8b9 (patch)
tree3a254019228a4d374219f9c6614b5f2477cba69f /gnu/packages/ocaml.scm
parent1276f9da9a2bce286da6cdda5d1e4d3d1870b3c3 (diff)
gnu: Add ocaml-bheap.
* gnu/packages/ocaml.scm (ocaml-bheap): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5b915a532a..a1f691c655 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3107,6 +3107,28 @@ The client and the server libraries have sets of unit-tests.")
avoid copying the data contained within the page.")
(license license:isc)))
+(define-public ocaml-bheap
+ (package
+ (name "ocaml-bheap")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/backtracking/bheap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b8md5zl4yz7j62jz0bf7lwyl0pyqkxqx36ghkgkbkxb4zzggfj1"))))
+ (build-system dune-build-system)
+ (native-inputs (list ocaml-stdlib-shims))
+ (home-page "https://github.com/backtracking/bheap")
+ (synopsis "Priority queues")
+ (description
+ "Traditional implementation of priority queues using a binary heap
+encoded in a resizable array.")
+ (license license:lgpl2.1)))
+
(define-public ocaml-luv
(package
(name "ocaml-luv")