summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-22 18:36:56 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-24 02:13:39 +0100
commitb2a725c6792bfc278ee200f461a1765c28bd444b (patch)
tree5e929ee1bd67ea3628f29e0033b2563421bab9b8 /gnu/packages/ocaml.scm
parentd48b404cf577cbfcd29b294e193a4db0c3e580b1 (diff)
gnu: Add ocaml-trie.
* gnu/packages/ocaml.scm (ocaml-trie): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 123f05d568..5e195572ec 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 divoplade <d@divoplade.fr>
;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
@@ -7434,6 +7434,29 @@ between Bigstrings and other string-like types. @code{bigstringaf} provides
these missing pieces.")
(license license:bsd-3)))
+(define-public ocaml-trie
+ (package
+ (name "ocaml-trie")
+ (version "1.0.0")
+ (home-page "https://github.com/kandu/trie/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s7p9swjqjsqddylmgid6cv263ggq7pmb734z4k84yfcrgb6kg4g"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:tests? #f)) ;no tests
+ (synopsis "Strict impure trie tree")
+ (description
+ "This module implements strict impure trie tree data structure for
+OCaml.")
+ (license license:expat)))
+
(define-public ocaml-syntax-shims
(package
(name "ocaml-syntax-shims")