summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-07-27 23:31:57 -0400
committer宋文武 <iyzsong@member.fsf.org>2022-08-03 13:47:25 +0800
commitc99487c2356e6385425cd891db82810d333fa096 (patch)
treed365597f782e6b4de46edb4ce529e0f9efa507ab /gnu/packages/ocaml.scm
parentdca0a3ac9380f0d9fe9ef80092e4c997b239243a (diff)
gnu: Add ocaml-sha.
* gnu/packages/ocaml.scm (ocaml-sha): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index da7086ab2b..8620d2bde3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5930,6 +5930,28 @@ storage of large amounts of data.")
(description "Octavius is a library to parse the `ocamldoc` comment syntax.")
(license license:isc)))
+(define-public ocaml-sha
+ (package
+ (name "ocaml-sha")
+ (version "1.15.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/djs55/ocaml-sha/releases/download/"
+ version "/sha-" version ".tbz"))
+ (sha256
+ (base32
+ "1dzzhchknnbrpp5s81iqbvmqp4s0l75yrq8snj70ch3wkarmgg9z"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-stdlib-shims ocaml-odoc))
+ (native-inputs (list ocaml-ounit2))
+ (home-page "https://github.com/djs55/ocaml-sha")
+ (synopsis "OCaml binding to the SHA cryptographic functions")
+ (description
+ "This is the binding for SHA interface code in OCaml, offering the same
+interface as the MD5 digest included in the OCaml standard library. It
+currently provides SHA1, SHA256 and SHA512 hash functions.")
+ (license license:isc)))
+
(define-public ocaml-ppx-hash
(package
(name "ocaml-ppx-hash")