summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 00:20:42 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 00:20:42 +0100
commitcebc0e54a473c78bf0ad4c255ae7bef660b05e78 (patch)
treeb7279ea6aa8433c7f5899fe72966059a4aba294e /gnu/packages/ocaml.scm
parentbe9ae1347c7eb9508b79661232372559bfe03711 (diff)
gnu: Add ocaml4.07-base64.
* gnu/packages/ocaml.scm (ocaml4.07-base64): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 146040702b..8bbc6fb6a3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2986,6 +2986,7 @@ multitude of other network protocols (FTP/SMTP/RTSP/etc).")
`(("ocaml-alcotest" ,ocaml-alcotest)
("ocaml-bos" ,ocaml-bos)
("ocaml-rresult" ,ocaml-rresult)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-base64))))
(home-page "https://github.com/mirage/ocaml-base64")
(synopsis "Base64 encoding for OCaml")
(description "Base64 is a group of similar binary-to-text encoding schemes
@@ -2993,6 +2994,25 @@ that represent binary data in an ASCII string format by translating it into a
radix-64 representation. It is specified in RFC 4648.")
(license license:isc)))
+(define-public ocaml4.07-base64
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-base64)
+ (version "3.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ocaml-base64")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "ocaml-base64" version))
+ (sha256
+ (base32
+ "1ilw3zj0w6cq7i4pvr8m2kv5l5f2y9aldmv72drlwwns013b1gwy"))))
+ (arguments
+ ;; Tests are likely incompatible with our recent alcotest
+ `(#:tests? #f))
+ (properties '()))))
+
(define-public ocamlify
(package
(name "ocamlify")