summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-24 14:21:36 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-24 14:50:46 +0100
commitdb61ad142da1b1b60a6aaec61773df75b6e282f8 (patch)
tree19621db688b0c9d5cb3ab56c58e624fb0cda185c /gnu/packages/ocaml.scm
parent9cc8ee15d09fa8953a7643626eee02efa9237b16 (diff)
gnu: Add ocaml-benchmark.
* gnu/packages/ocaml.scm (ocaml-benchmark): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 82a675dc3d..69d37f37bc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3182,6 +3182,29 @@ many additional enhancements, including:
license:gpl2)))) ; OMake itself, with ocaml linking exception
; see LICENSE.OMake
+(define-public ocaml-benchmark
+ (package
+ (name "ocaml-benchmark")
+ (version "1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Chris00/ocaml-benchmark")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0d0vdfjgjzf1y6wkd714d8b0piv1z9qav5ahsapynqzk4b4ahhnp"))))
+ (build-system dune-build-system)
+ (arguments `(#:test-target "tests"))
+ (home-page "https://github.com/Chris00/ocaml-benchmark")
+ (synopsis "Benchmark running times of code")
+ (description
+ "This module provides a set of tools to measure the running times of
+your functions and to easily compare the results. A statistical test
+is used to determine whether the results truly differ.")
+ (license license:lgpl3+)))
+
(define-public ocaml-batteries
(package
(name "ocaml-batteries")