summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-26 00:06:41 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 19:39:54 +0100
commitf9bf7de5b4c208804efbe84bd8b3c019d3caee05 (patch)
treecee8197bd83b29d8a8a99f8924b2c691a8ea502b /gnu/packages/ocaml.scm
parent0481810ebfaae1973643455088b4e2cab0a941f1 (diff)
gnu: Add ocaml-gsl.
* gnu/packages/ocaml.scm (ocaml4.07-gsl): Replace with... (ocaml-gsl): ...this. Use latest ocaml package. (ocaml4.07-gsl-1): Adapt accordingly.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm53
1 files changed, 24 insertions, 29 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 99a6058e63..72cc3df230 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4764,9 +4764,9 @@ External contributors added support for Visual Studio Code, Sublime Text and
Atom.")
(license license:expat)))
-(define-public ocaml4.07-gsl
+(define-public ocaml-gsl
(package
- (name "ocaml4.07-gsl")
+ (name "ocaml-gsl")
(version "1.24.0")
(source
(origin
@@ -4786,16 +4786,12 @@ Atom.")
(add-after 'unpack 'fix-gsl-directory
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/config/discover.ml"
- (("/usr") (assoc-ref inputs "gsl")))
- #t)))
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ (("/usr") (assoc-ref inputs "gsl"))))))))
(inputs
`(("gsl" ,gsl)))
(propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))))
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-stdio" ,ocaml-stdio)))
(home-page "https://mmottl.github.io/gsl-ocaml")
(synopsis "Bindings to the GNU Scientific Library")
(description
@@ -4804,26 +4800,25 @@ the OCaml language.")
(license license:gpl3+)))
(define-public ocaml4.07-gsl-1
- (package
- (inherit ocaml4.07-gsl)
- (version "1.19.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mmottl/gsl-ocaml"
- "/releases/download/v"
- version "/gsl-ocaml-" version ".tar.gz"))
- (sha256
- (base32
- "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
- (build-system ocaml-build-system)
- (inputs
- `(("gsl" ,gsl)))
- (native-inputs
- `(("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))))
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib))
- (propagated-inputs '())))
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-gsl)
+ (version "1.19.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mmottl/gsl-ocaml"
+ "/releases/download/v"
+ version "/gsl-ocaml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("gsl" ,gsl)))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)))
+ (arguments '())
+ (propagated-inputs '()))))
(define-public cubicle
(package