summaryrefslogtreecommitdiff
path: root/gnu/packages/opencl.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-11 21:35:58 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-27 20:50:56 +0200
commit9c7c3f771c0a9f0ec94106127f4ac25b8dcf7557 (patch)
tree5cbbf2c897ea8402f9748aadd9e80de2c1cec364 /gnu/packages/opencl.scm
parent65a5eec0a1dca47716767fe9b76ea817843d3942 (diff)
gnu: python-pyopencl: Update to 2021.2.6.
* gnu/packages/opencl.scm (python-pyopencl)[version]: Update to 2021.2.6. [source]: Point to new git repository. [#:phases]: Remove unused phases. [inputs]: Use unversioned opencl-headers. [propagated-inputs]: Remove unused inputs.
Diffstat (limited to 'gnu/packages/opencl.scm')
-rw-r--r--gnu/packages/opencl.scm25
1 files changed, 5 insertions, 20 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 70d917c11f..2d5ccf0105 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -364,44 +364,29 @@ A lexer, @code{pytools.lex}.
(define-public python-pyopencl
(package
(name "python-pyopencl")
- (version "2019.1.1")
+ (version "2021.2.6")
(source
(origin
- ;; The tarball on PyPI lacks test programs such as
- ;; 'pygpu_language_opencl.cpp' so fetch it from Git.
- ;; XXX: The server at git.tiker.net is unreliable.
(method git-fetch)
(uri (git-reference
- (url "http://git.tiker.net/trees/pyopencl.git")
+ (url "https://github.com/inducer/pyopencl.git")
(commit (string-append "v" version))
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "12q0rs8yla571vcfpsh0mfrjbdiayv0hi8r1rq0f178m3i3qjz80"))))
+ "1s2cls7avxvf753zzpx422ikslaxdnm8rz58zg7mal15yak0wv2x"))))
(build-system python-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'build 'set-home
- (lambda _
- ;; Some of the Python build scripts expect 'HOME' to be
- ;; set.
- (setenv "HOME" (getcwd))
- #t)))
-
- ;; Tests in 'compyte/ndarray/setup_opencl.py' appear to rely on
- ;; 'nvcc', which is not an option.
- #:tests? #f))
+ `(#:tests? #f)) ; Tests cannot find pygpu_language_opencl.cpp
(inputs
- `(("opencl-headers" ,opencl-headers-1.2) ;POCL only supports OpenCL 1.2
+ `(("opencl-headers" ,opencl-headers)
("pybind11" ,pybind11)
("opencl-icd-loader" ,opencl-icd-loader))) ;libOpenCL
(propagated-inputs
`(("python-appdirs" ,python-appdirs)
- ("python-decorator" ,python-decorator)
("python-numpy" ,python-numpy)
("python-pytools" ,python-pytools)
- ("python-six" ,python-six)
("python-mako" ,python-mako)))
(home-page "http://mathema.tician.de/software/pyopencl")
(synopsis "Python wrapper for OpenCL")