summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-24 22:40:33 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-24 23:40:50 +0200
commit30f25b033c7fbcdcc7050b1655fc832252255c7e (patch)
tree8fdfdf73d4cd5fdf6812a4fb78269a5ac35991f0 /gnu/packages/package-management.scm
parent2d195e677562f34e00137561911a5b84796059f6 (diff)
gnu: vm: Initialize the image's store.
* gnu/system/vm.scm (qemu-image): Add 'initialize-store?' keyword parameter. Use 'guix-register' when INITIALIZE-STORE? is true. (system-qemu-image): Pass #:initialize-store? #t.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 87fa008002..e19ce04716 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -103,3 +103,14 @@ A user-land free software distribution for GNU/Linux comes as part of Guix.
Guix is based on the Nix package manager.")
(license gpl3+)))
+
+(define-public guix-0.4
+ ;; XXX: Hack to allow the use of a 0.4ish tarball. This assumes that you
+ ;; have run 'make dist' in your build tree. Remove when 0.4 is out.
+ (package (inherit guix)
+ (version "0.4rc")
+ (source (let ((builddir (dirname
+ (canonicalize-path
+ (dirname (search-path %load-path
+ "guix/config.scm"))))))
+ (string-append builddir "/guix-0.4.tar.gz")))))