summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/apr-fix-atomics.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-11 20:19:52 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-11 20:19:52 +0800
commit770f3f587d35e32aba3c6cb0b606f2d2fe8d5ace (patch)
tree7e15565a6959867d4bb1bdaf446bbfaff6235259 /gnu/packages/patches/apr-fix-atomics.patch
parent446ec58af67910191be1be06efda6c43fc3cf8d7 (diff)
parentad4520b92662e42d7d0b1e648b2068300dbb95c8 (diff)
Merge remote-tracking branch 'origin/master' into kde-updates
Diffstat (limited to 'gnu/packages/patches/apr-fix-atomics.patch')
-rw-r--r--gnu/packages/patches/apr-fix-atomics.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/patches/apr-fix-atomics.patch b/gnu/packages/patches/apr-fix-atomics.patch
new file mode 100644
index 0000000000..94cce9b5f1
--- /dev/null
+++ b/gnu/packages/patches/apr-fix-atomics.patch
@@ -0,0 +1,49 @@
+This patch is taken from Debian, using Debian version 1.7.0-8.
+A new patch will be needed when apr is updated.
+
+# quick and dirty fix for FTBFS on mipsel
+# There should be a proper configure check, see
+# https://bz.apache.org/bugzilla/show_bug.cgi?id=63566
+Index: apr-1.7.0/include/arch/unix/apr_arch_atomic.h
+===================================================================
+--- apr-1.7.0.orig/include/arch/unix/apr_arch_atomic.h
++++ apr-1.7.0/include/arch/unix/apr_arch_atomic.h
+@@ -26,6 +26,9 @@
+ /* noop */
+ #elif HAVE_ATOMIC_BUILTINS
+ # define USE_ATOMICS_BUILTINS
++# if (__INTPTR_WIDTH__ == 32) && ( defined(__MIPSEL__) || defined(__powerpc__) ) || defined(__m68k__) || defined(__sh__)
++# define NEED_ATOMICS_GENERIC64
++# endif
+ #elif defined(SOLARIS2) && SOLARIS2 >= 10
+ # define USE_ATOMICS_SOLARIS
+ # define NEED_ATOMICS_GENERIC64
+Index: apr-1.7.0/atomic/unix/builtins64.c
+===================================================================
+--- apr-1.7.0.orig/atomic/unix/builtins64.c
++++ apr-1.7.0/atomic/unix/builtins64.c
+@@ -16,7 +16,7 @@
+
+ #include "apr_arch_atomic.h"
+
+-#ifdef USE_ATOMICS_BUILTINS
++#if defined(USE_ATOMICS_BUILTINS) && ! defined(NEED_ATOMICS_GENERIC64)
+
+ APR_DECLARE(apr_uint64_t) apr_atomic_read64(volatile apr_uint64_t *mem)
+ {
+Index: apr-1.7.0/atomic/unix/builtins.c
+===================================================================
+--- apr-1.7.0.orig/atomic/unix/builtins.c
++++ apr-1.7.0/atomic/unix/builtins.c
+@@ -20,7 +20,11 @@
+
+ APR_DECLARE(apr_status_t) apr_atomic_init(apr_pool_t *p)
+ {
++#if defined (NEED_ATOMICS_GENERIC64)
++ return apr__atomic_generic64_init(p);
++#else
+ return APR_SUCCESS;
++#endif
+ }
+
+ APR_DECLARE(apr_uint32_t) apr_atomic_read32(volatile apr_uint32_t *mem)