summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audacity-ffmpeg-fallback.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-26 23:53:18 +0100
committerMarius Bakke <marius@gnu.org>2022-11-27 21:19:49 +0100
commitae64c4ac89c18a44f0240f403b4c290e31a62461 (patch)
treef12731f3590591993f9281e5f0b7fec0a84989f8 /gnu/packages/patches/audacity-ffmpeg-fallback.patch
parentec10258c34c454295411be7dacf44d4ec5b9c152 (diff)
gnu: audacity: Update to 3.2.1.
* gnu/packages/audio.scm (audacity): Update to 3.2.1. [source]: Switch to GIT-FETCH. [inputs]: Remove LIBMAD. Add MPG123 and WAVPACK. [arguments]: Add configure flag to prevent spurious dependency. Adjust fix-cmake-rpath phase. Delete obsolete phases. * gnu/packages/patches/audacity-ffmpeg-fallback.patch: Adjust for 3.2.1.
Diffstat (limited to 'gnu/packages/patches/audacity-ffmpeg-fallback.patch')
-rw-r--r--gnu/packages/patches/audacity-ffmpeg-fallback.patch23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/patches/audacity-ffmpeg-fallback.patch b/gnu/packages/patches/audacity-ffmpeg-fallback.patch
index b78956070a..d18583c9bd 100644
--- a/gnu/packages/patches/audacity-ffmpeg-fallback.patch
+++ b/gnu/packages/patches/audacity-ffmpeg-fallback.patch
@@ -8,13 +8,11 @@ it. This dynamic loading mechanism fails to properly locate libraries outside
of LD_LIBRARY_PATH.
See <https://issues.guix.gnu.org/53591>.
----
- libraries/lib-ffmpeg-support/CMakeLists.txt | 8 ++++++++
- libraries/lib-ffmpeg-support/FFmpegFunctions.cpp | 12 ++++++++++++
- 2 files changed, 20 insertions(+)
+
+Bugs-added-by: Marius Bakke <marius@gnu.org>
diff --git a/libraries/lib-ffmpeg-support/CMakeLists.txt b/libraries/lib-ffmpeg-support/CMakeLists.txt
-index 8c5f06d7c..00810e4d0 100644
+index b8803a1f5..f86559cca 100644
--- a/libraries/lib-ffmpeg-support/CMakeLists.txt
+++ b/libraries/lib-ffmpeg-support/CMakeLists.txt
@@ -1,5 +1,7 @@
@@ -25,7 +23,7 @@ index 8c5f06d7c..00810e4d0 100644
set( SOURCES
FFmpegTypes.h
-@@ -100,6 +102,12 @@ if (${_OPT}use_ffmpeg)
+@@ -107,6 +109,12 @@ if (${_OPT}use_ffmpeg)
list(APPEND DEFINITIONS PRIVATE _DARWIN_C_SOURCE )
endif()
@@ -39,10 +37,10 @@ index 8c5f06d7c..00810e4d0 100644
"${DEFINITIONS}" ""
)
diff --git a/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp b/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-index 66d085a0b..4eeb4aed3 100644
+index 55d6f676b..46640ef83 100644
--- a/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
+++ b/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-@@ -238,6 +238,18 @@ struct FFmpegFunctions::Private final
+@@ -246,6 +246,18 @@ struct FFmpegFunctions::Private final
if (library->IsLoaded())
return library;
@@ -58,9 +56,6 @@ index 66d085a0b..4eeb4aed3 100644
+ }
+#endif
+
- // Loading has failed.
- // wxLogSysError doesn't report errors correctly on *NIX
- #if defined(_WIN32)
---
-2.34.0
-
+ return {};
+ }
+ };