summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/awesome-reproducible-png.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-17 15:48:27 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-17 15:48:27 +0200
commitc0eeccbc2486572de1ef88249c63bc71c28dfef6 (patch)
treea265eb0b77b3b876844662da5bc9b32c549209e0 /gnu/packages/patches/awesome-reproducible-png.patch
parent56501d3b1727cbafed25be4268c4e6c9387088d9 (diff)
parenta1b484654af07303813a215d4e04c0e4e7b199e5 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/awesome-reproducible-png.patch')
-rw-r--r--gnu/packages/patches/awesome-reproducible-png.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/awesome-reproducible-png.patch b/gnu/packages/patches/awesome-reproducible-png.patch
new file mode 100644
index 0000000000..0fae65bc71
--- /dev/null
+++ b/gnu/packages/patches/awesome-reproducible-png.patch
@@ -0,0 +1,14 @@
+Do not introduce timestamps in PNG files (for icons).
+See <https://wiki.debian.org/ReproducibleBuilds/TimestampsInPNG>.
+
+--- awesome-3.4.15/CMakeLists.txt 2013-02-11 14:50:21.000000000 +0100
++++ awesome-3.4.15/CMakeLists.txt 2016-06-16 13:59:30.528125439 +0200
+@@ -295,7 +295,7 @@ macro(a_icon_convert match replacement i
+ set(ALL_ICONS ${ALL_ICONS} ${output})
+
+ add_custom_command(
+- COMMAND ${CONVERT_EXECUTABLE} ${input} ${ARGN} ${output}
++ COMMAND ${CONVERT_EXECUTABLE} +set date:create +set date:modify -define png:exclude-chunk=time ${input} ${ARGN} ${output}
+ OUTPUT ${output}
+ DEPENDS ${input}
+ VERBATIM)