summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-c-auth-install-private-headers.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 17:43:35 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:51 +0100
commit05be89ac5b592c798976d97dce920734b7e7fa55 (patch)
tree291719a3e1d9a37a3cf148288a2a5b115df5913d /gnu/packages/patches/aws-c-auth-install-private-headers.patch
parentcff8a12a0a23f09fe1bc0d55f8d7e35ca6054ba0 (diff)
gnu: aws-c-auth: Update to 0.6.4.
* gnu/packages/c.scm (aws-c-auth): Update to 0.6.4. [arguments]: Fix CMAKE_PREFIX_PATH, disable network tests. [source]: Add and remove patches. * gnu/packages/patches/aws-c-auth-install-private-headers.patch: New file. * gnu/packages/patches/aws-c-auth-cmake-prefix.patch, gnu/packages/patches/aws-c-auth-disable-networking-tests.patch: Delete files. * gnu/local.mk: Add and remove them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-c-auth-install-private-headers.patch')
-rw-r--r--gnu/packages/patches/aws-c-auth-install-private-headers.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-auth-install-private-headers.patch b/gnu/packages/patches/aws-c-auth-install-private-headers.patch
new file mode 100644
index 0000000000..990fd6f2eb
--- /dev/null
+++ b/gnu/packages/patches/aws-c-auth-install-private-headers.patch
@@ -0,0 +1,19 @@
+aws-sdk-cpp depends on the private headers from aws-c-auth. This dependency was
+added to aws-sdk-cpp in commit 23cca02c2df on 2021-06-04.
+
+The following error is generated when building aws-sdk-cpp when the private
+aws-c-auth headers are not installed:
+
+/tmp/guix-build-aws-sdk-cpp-1.9.121.drv-0/aws-sdk-cpp-1.9.121-checkout/aws-cpp-sdk-core-tests/aws/auth/AWSAuthSignerTest.cpp:17:10: fatal error: aws/auth/private/aws_signing.h: No such file or directory
+ #include <aws/auth/private/aws_signing.h>
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -110,6 +114,7 @@ target_link_libraries(${PROJECT_NAME} PUBLIC ${DEP_AWS_LIBS} ${PLATFORM_LIBS})
+ aws_prepare_shared_lib_exports(${PROJECT_NAME})
+
+ install(FILES ${AWS_AUTH_ROOT_HEADERS} DESTINATION "include/aws/auth" COMPONENT Development)
++install(FILES ${AWS_AUTH_PRIVATE_HEADERS} DESTINATION "include/aws/auth/private" COMPONENT Development)
+
+ if (BUILD_SHARED_LIBS)
+ set (TARGET_DIR "shared")