summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/cogl-fix-double-free.patch
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-09-07 07:36:31 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 07:47:57 +0200
commit94a9b26bcfa5446ca1e98968ae47a8cc74a158dc (patch)
tree48ad4b5ab03877fe2c79399265a85f6cdf689701 /gnu/packages/patches/cogl-fix-double-free.patch
parent4ebc426602253490a25a4b567e2ac3b88192a3da (diff)
gnu: cogl: Fix double free.
This patch fixes a double free in cogl, which broke all of the test cases and thus also the package build itself. * gnu/packages/patches/cogl-fix-double-free.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/gnome.scm (cogl): Use it here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/patches/cogl-fix-double-free.patch')
-rw-r--r--gnu/packages/patches/cogl-fix-double-free.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/cogl-fix-double-free.patch b/gnu/packages/patches/cogl-fix-double-free.patch
new file mode 100644
index 0000000000..e7a994b33a
--- /dev/null
+++ b/gnu/packages/patches/cogl-fix-double-free.patch
@@ -0,0 +1,32 @@
+From 15d0f7d96cf53263196e26f2eb48ededdff0efeb Mon Sep 17 00:00:00 2001
+Message-ID: <15d0f7d96cf53263196e26f2eb48ededdff0efeb.1694148833.git.vivien@planete-kraus.eu>
+From: Vivien Kraus <vivien@planete-kraus.eu>
+Date: Thu, 7 Sep 2023 22:16:48 +0200
+Subject: [PATCH] Prevent double free on context objects
+
+The display is unrefed in the context destructor, but not refed in the
+constructor.
+
+This targets an archived (read-only) repository.
+---
+ cogl/cogl-context.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cogl/cogl-context.c b/cogl/cogl-context.c
+index a7eed29a..7cdc9fe7 100644
+--- a/cogl/cogl-context.c
++++ b/cogl/cogl-context.c
+@@ -218,7 +218,7 @@ cogl_context_new (CoglDisplay *display,
+ return NULL;
+ }
+
+- context->display = display;
++ context->display = cogl_object_ref (display);
+
+ /* This is duplicated data, but it's much more convenient to have
+ the driver attached to the context and the value is accessed a
+
+base-commit: 61d966c7442d521e38572b7f93ac7b8973a9c65e
+--
+2.41.0
+