summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/datefudge-gettimeofday.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-02-17 23:01:54 +0100
committerLudovic Courtès <ludo@gnu.org>2020-02-17 23:01:54 +0100
commiteb07edabaf11e39b25f5cf40967afd3dadcb14eb (patch)
tree2891cac86fc706587284a89ed5e3a4c9461d349f /gnu/packages/patches/datefudge-gettimeofday.patch
parent88f85494491a0cd4d4262c97860f01e99c2bc313 (diff)
gnu: datefudge: Fix compilation against libc 2.31.
* gnu/packages/patches/datefudge-gettimeofday.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/time.scm (datefudge)[source] Use it.
Diffstat (limited to 'gnu/packages/patches/datefudge-gettimeofday.patch')
-rw-r--r--gnu/packages/patches/datefudge-gettimeofday.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/datefudge-gettimeofday.patch b/gnu/packages/patches/datefudge-gettimeofday.patch
new file mode 100644
index 0000000000..11c7640869
--- /dev/null
+++ b/gnu/packages/patches/datefudge-gettimeofday.patch
@@ -0,0 +1,13 @@
+Add the 'restrict' qualifier to match the 'gettimeofday' declaration found
+in glibc 2.31.
+
+--- datefudge-1.23/datefudge.c 2020-02-17 22:35:21.343341725 +0100
++++ datefudge-1.23/datefudge.c 2020-02-17 22:35:49.619117874 +0100
+@@ -78,6 +78,6 @@
+ return 0;
+ }
+
+-int gettimeofday(struct timeval *x, struct timezone *y) {
++int gettimeofday(struct timeval *restrict x, void *restrict y) {
+ return __gettimeofday(x,y);
+ }