summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-18 15:58:24 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-18 16:03:22 +0200
commitd98542a6a95fd71e3aab79a9c1c0cc6700caad4c (patch)
treecaaeb2c42ab068f3340cb9d4b34b4740b74d8d39 /gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch
parent9a4ea7059d33caebe54406b77397dd118be9ea88 (diff)
gnu: Add missing emacs-polymode patch.
This fixes up commit 52e55b38f446784209866dcf4bff23b7f604ba24. * gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch: New file.
Diffstat (limited to 'gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch')
-rw-r--r--gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch b/gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch
new file mode 100644
index 0000000000..77a8452c2a
--- /dev/null
+++ b/gnu/packages/patches/emacs-polymode-fix-lexical-variable-error.patch
@@ -0,0 +1,37 @@
+From 8b83fa772a71efc9dc030c43db2cba944e4338c1 Mon Sep 17 00:00:00 2001
+From: Kien Nguyen <kien.n.quang@gmail.com>
+Date: Wed, 19 May 2021 23:15:01 +0900
+Subject: [PATCH] Fix using of temporary lexical variable causes error in
+ native compiling
+
+---
+ polymode-core.el | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/polymode-core.el b/polymode-core.el
+index e7d40be..ef316f8 100644
+--- a/polymode-core.el
++++ b/polymode-core.el
+@@ -2088,14 +2088,14 @@ Elements of LIST can be either strings or symbols."
+ (stringp pm--output-file)
+ (pm--file-mod-time pm--output-file)))
+ (imt (and omt (pm--file-mod-time pm--input-file)))
+- (action (if is-exporter "exporting" "weaving"))
+ (ofile (if (and imt (time-less-p imt omt))
+ (progn
+ (message "Not re-%s as input file '%s' hasn't changed"
+- (file-name-nondirectory ifile) action)
++ (if is-exporter "exporting" "weaving")
++ (file-name-nondirectory ifile))
+ pm--output-file)
+ (message "%s '%s' with '%s' ..."
+- (capitalize action)
++ (if is-exporter "EXPORTING" "WEAVING")
+ (file-name-nondirectory ifile)
+ (eieio-object-name processor))
+ (let ((fn (with-no-warnings
+
+base-commit: 44265e35161d77f6eaa09388ea2256b89bd5dcc8
+--
+2.37.2
+