summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-shx-byte-compilation-test.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-19 14:15:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-19 15:05:53 -0500
commitd6170e03e39075c3f781e790ab2f7c4caab25358 (patch)
tree9309ca0f682d5f5a85e95b1913784f4cafc6b941 /gnu/packages/patches/emacs-shx-byte-compilation-test.patch
parent33f12b7dcd41c3d1ba1bd1a6301c5512ac194cee (diff)
gnu: emacs-shx: Fix test failure.
* gnu/packages/patches/emacs-shx-byte-compilation-test.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/emacs-xyz.scm (emacs-shx): Apply it. Change-Id: I6d8edd3b50f99f1c4cd495216caf9648dfee4ea3
Diffstat (limited to 'gnu/packages/patches/emacs-shx-byte-compilation-test.patch')
-rw-r--r--gnu/packages/patches/emacs-shx-byte-compilation-test.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-shx-byte-compilation-test.patch b/gnu/packages/patches/emacs-shx-byte-compilation-test.patch
new file mode 100644
index 0000000000..b0f4714a6c
--- /dev/null
+++ b/gnu/packages/patches/emacs-shx-byte-compilation-test.patch
@@ -0,0 +1,35 @@
+From 6e8cb6f2175cd5c108de615a970a27877adfaea0 Mon Sep 17 00:00:00 2001
+From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
+Date: Fri, 19 Jan 2024 10:49:51 -0500
+Subject: [PATCH] tests: Fix byte-compilation test.
+
+* test/shx-test.el (shx-test-unit-byte-compile): Simply assert on the
+return value of byte-compile-file, which is non-nil when there are no
+errors.
+
+Fixes: <https://github.com/riscy/shx-for-emacs/issues/33>
+---
+ test/shx-test.el | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/test/shx-test.el b/test/shx-test.el
+index e18cefb..ed5aee3 100644
+--- a/test/shx-test.el
++++ b/test/shx-test.el
+@@ -83,10 +83,8 @@ Example:
+ "Test byte-compilation against the shx.el file."
+ (ignore-errors (kill-buffer "*Compile-Log*"))
+ (let ((file (replace-regexp-in-string ".elc$" ".el" (symbol-file 'shx-mode))))
+- (byte-compile-file file)
+ (shx-test-assert "shx.el passes byte-compilation"
+- (with-current-buffer (get-buffer-create "*Compile-Log*")
+- (<= (- (point-max) (point)) 3)))))
++ (byte-compile-file file))))
+
+ (defun shx-test-unit-declare-function ()
+ "Test `declare-function'."
+
+base-commit: b99d16f36bc278d668d8428c4bc9af77064c336a
+--
+2.41.0
+