summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-xelb-ignore-length-element.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-19 22:32:58 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-19 22:32:58 +0200
commit04a4fe2df2f1876a3b4ce5fb7405f4bd940feeb7 (patch)
treef8f9ef6fbaedf58dd0fa80ed751d6ef6cd114421 /gnu/packages/patches/emacs-xelb-ignore-length-element.patch
parent4f4c38c881d4224dc545c82253d2a8f631f95927 (diff)
gnu: emacs-xelb: Fix compilation error with xcb-proto@1.15.
* gnu/packages/patches/emacs-xelb-ignore-length-element.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emacs-xyz.scm (emacs-xelb): Use it.
Diffstat (limited to 'gnu/packages/patches/emacs-xelb-ignore-length-element.patch')
-rw-r--r--gnu/packages/patches/emacs-xelb-ignore-length-element.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-xelb-ignore-length-element.patch b/gnu/packages/patches/emacs-xelb-ignore-length-element.patch
new file mode 100644
index 0000000000..48c3e35155
--- /dev/null
+++ b/gnu/packages/patches/emacs-xelb-ignore-length-element.patch
@@ -0,0 +1,19 @@
+Work around build failure due to XCB "length" element.
+Patch from <https://sources.debian.org/patches/xelb/0.18-4/>.
+
+Author: Martin <debacle@debian.org>
+Bug: https://github.com/ch11ng/xelb/issues/28
+Bug-Debian: https://bugs.debian.org/1017294
+
+---
+--- a/el_client.el
++++ b/el_client.el
+@@ -519,7 +519,7 @@
+ (`list (xelb-parse-list node))
+ (`exprfield (xelb-parse-exprfield node))
+ (`switch (xelb-parse-switch node))
+- ((or `comment `doc)) ;simply ignored
++ ((or `comment `doc `length)) ;simply ignored
+ (x (error "Unsupported structure content: <%s>" x))))
+
+ ;; The car of the result shall be renamed to prevent duplication of slot names