summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fxdiv-system-libraries.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-07-29 15:42:10 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-29 21:54:54 +0200
commita9bc8a25eb9a5851062167a3475622ba6b1a8b9a (patch)
treef579f30adf7eac4259d310276ab936dfa5d2338e /gnu/packages/patches/fxdiv-system-libraries.patch
parentffb381856d0c6cc1a557b789f6b377cfa17002a0 (diff)
gnu: Add FXDiv.
* gnu/packages/maths.scm (fxdiv): New variable. * gnu/packages/patches/fxdiv-system-libraries.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/fxdiv-system-libraries.patch')
-rw-r--r--gnu/packages/patches/fxdiv-system-libraries.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/patches/fxdiv-system-libraries.patch b/gnu/packages/patches/fxdiv-system-libraries.patch
new file mode 100644
index 0000000000..eecfaf7efc
--- /dev/null
+++ b/gnu/packages/patches/fxdiv-system-libraries.patch
@@ -0,0 +1,44 @@
+This patch allows the build process to use the provided dependencies instead
+of adding their source as CMake sub-directories (in which case "make install"
+would install googletest's and googlebenchmark's libraries and headers).
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bcae6b5..ff6710d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,7 +21,7 @@ IF(FXDIV_BUILD_TESTS)
+ ENDIF()
+
+ # ---[ Download deps
+-IF(FXDIV_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
++IF(FALSE)
+ MESSAGE(STATUS "Downloading Google Test to ${CMAKE_BINARY_DIR}/googletest-source (define GOOGLETEST_SOURCE_DIR to avoid it)")
+ CONFIGURE_FILE(cmake/DownloadGoogleTest.cmake "${CMAKE_BINARY_DIR}/googletest-download/CMakeLists.txt")
+ EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
+@@ -31,7 +31,7 @@ IF(FXDIV_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
+ SET(GOOGLETEST_SOURCE_DIR "${CMAKE_BINARY_DIR}/googletest-source" CACHE STRING "Google Test source directory")
+ ENDIF()
+
+-IF(FXDIV_BUILD_BENCHMARKS AND NOT DEFINED GOOGLEBENCHMARK_SOURCE_DIR)
++IF(FALSE)
+ MESSAGE(STATUS "Downloading Google Benchmark to ${CMAKE_BINARY_DIR}/googlebenchmark-source (define GOOGLEBENCHMARK_SOURCE_DIR to avoid it)")
+ CONFIGURE_FILE(cmake/DownloadGoogleBenchmark.cmake "${CMAKE_BINARY_DIR}/googlebenchmark-download/CMakeLists.txt")
+ EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
+@@ -54,7 +54,7 @@ INSTALL(FILES include/fxdiv.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ IF(FXDIV_BUILD_TESTS)
+ # ---[ Build google test
+- IF(NOT TARGET gtest)
++ IF(FALSE)
+ SET(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+ ADD_SUBDIRECTORY(
+ "${GOOGLETEST_SOURCE_DIR}"
+@@ -78,7 +78,7 @@ ENDIF()
+
+ IF(FXDIV_BUILD_BENCHMARKS)
+ # ---[ Build google benchmark
+- IF(NOT TARGET benchmark)
++ IF(FALSE)
+ SET(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
+ ADD_SUBDIRECTORY(
+ "${GOOGLEBENCHMARK_SOURCE_DIR}"