summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/geoclue-config.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-22 21:14:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 20:55:46 -0400
commitbbe444bcc176b07033c9711a4d3718dcf8720ea8 (patch)
tree4168b8f8382a45f1f424af4c65f497efd92db341 /gnu/packages/patches/geoclue-config.patch
parent5f7b0141d627b76fa721493c250006d472576c7c (diff)
gnu: geoclue: Update to 2.6.0 and remove input labels.
* gnu/packages/gnome.scm (geoclue): Update to 2.6.0. [native-inputs]: Replace intltool with gettext-minimal. Add vala. [inputs]: Delete labels. * gnu/packages/patches/geoclue-config.patch: Refresh patch.
Diffstat (limited to 'gnu/packages/patches/geoclue-config.patch')
-rw-r--r--gnu/packages/patches/geoclue-config.patch30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/patches/geoclue-config.patch b/gnu/packages/patches/geoclue-config.patch
index dd35b90be5..a3a6694cf7 100644
--- a/gnu/packages/patches/geoclue-config.patch
+++ b/gnu/packages/patches/geoclue-config.patch
@@ -1,25 +1,25 @@
-Allow the configuration file to be specified via an environment variable.
-
---- geoclue-2.1.10/src/gclue-config.c 2015-04-07 09:50:07.721074380 +0200
-+++ geoclue-2.1.10/src/gclue-config.c 2015-04-07 10:27:26.613171960 +0200
-@@ -235,6 +235,11 @@
+diff --git a/src/gclue-config.c b/src/gclue-config.c
+index 7ab2a67..e41f3df 100644
+--- a/src/gclue-config.c
++++ b/src/gclue-config.c
+@@ -332,6 +332,11 @@ static void
gclue_config_init (GClueConfig *config)
{
GError *error = NULL;
+ const char *config_file_path;
+
+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
-+ if (config_file_path == NULL)
-+ config_file_path = CONFIG_FILE_PATH;
++ if (!config_file_path)
++ config_file_path = CONFIG_FILE_PATH;
- config->priv =
- G_TYPE_INSTANCE_GET_PRIVATE (config,
-@@ -242,7 +247,7 @@
- GClueConfigPrivate);
+ config->priv = gclue_config_get_instance_private(config);
config->priv->key_file = g_key_file_new ();
- g_key_file_load_from_file (config->priv->key_file,
-- CONFIG_FILE_PATH,
-+ config_file_path,
- 0,
+@@ -341,7 +346,7 @@ gclue_config_init (GClueConfig *config)
&error);
if (error != NULL) {
+ g_critical ("Failed to load configuration file '%s': %s",
+- CONFIG_FILE_PATH, error->message);
++ config_file_path, error->message);
+ g_error_free (error);
+
+ return;