summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnash-fix-giflib-version.patch
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-11-25 14:18:56 -0300
committerChristopher Baines <mail@cbaines.net>2020-11-28 15:56:08 +0000
commitc76d0201f7cc639f51dbf259779d86dad62417cd (patch)
tree29c64f4cccb022f282ef942b60a06dddbb7064bf /gnu/packages/patches/gnash-fix-giflib-version.patch
parente2b4450d188320783a35086d52c14ac9d47cf7f0 (diff)
gnu: Add gnash.
* gnu/packages/animation.scm (gnash): New variable. * gnu/packages/patches/gnash-fix-giflib-version: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches/gnash-fix-giflib-version.patch')
-rw-r--r--gnu/packages/patches/gnash-fix-giflib-version.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnash-fix-giflib-version.patch b/gnu/packages/patches/gnash-fix-giflib-version.patch
new file mode 100644
index 0000000000..44816d2a14
--- /dev/null
+++ b/gnu/packages/patches/gnash-fix-giflib-version.patch
@@ -0,0 +1,17 @@
+Description: Change GIFLIB_MINOR to allow matching with v5.2+
+Source: https://savannah.gnu.org/patch/index.php?9873
+Author: marius851000
+
+diff --git a/libbase/GnashImageGif.cpp b/libbase/GnashImageGif.cpp
+index 2ae5ddb..b87b1e7 100644
+--- a/libbase/GnashImageGif.cpp
++++ b/libbase/GnashImageGif.cpp
+@@ -120,7 +120,7 @@ GifInput::GifInput(std::shared_ptr<IOChannel> in)
+ GifInput::~GifInput()
+ {
+ // Clean up allocated data.
+-#if GIFLIB_MAJOR==5 && GIFLIB_MINOR==1
++#if GIFLIB_MAJOR==5 && GIFLIB_MINOR!=0
+ DGifCloseFile(_gif, 0);
+ #else
+ DGifCloseFile(_gif);