summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/go-skip-gc-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
commitd1f3b333e6176a7879ab3742bbebb2a99f61a528 (patch)
tree8bd82ce68bd2534a48bf13c7256997f82dd1b3f4 /gnu/packages/patches/go-skip-gc-test.patch
parente01d384efcdaf564bbb221e43b81e087c8e2af06 (diff)
parent861907f01efb1cae7f260e8cb7b991d5034a486a (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/go-skip-gc-test.patch')
-rw-r--r--gnu/packages/patches/go-skip-gc-test.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/go-skip-gc-test.patch b/gnu/packages/patches/go-skip-gc-test.patch
new file mode 100644
index 0000000000..2baab97580
--- /dev/null
+++ b/gnu/packages/patches/go-skip-gc-test.patch
@@ -0,0 +1,17 @@
+Skip a GC test known to be flaky:
+
+ https://issues.guix.gnu.org/issue/37425
+ https://github.com/golang/go/issues/27636
+
+--- go/src/runtime/gc_test.go 2019-09-16 23:10:18.200680387 +0200
++++ go/src/runtime/gc_test.go 2019-09-16 23:11:50.324360646 +0200
+@@ -27,6 +27,9 @@ func TestGcSys(t *testing.T) {
+ if runtime.GOOS == "linux" && runtime.GOARCH == "arm64" {
+ t.Skip("skipping test; GOOS=linux GOARCH=arm64 https://github.com/golang/go/issues/27636")
+ }
++ if runtime.GOOS == "linux" {
++ t.Skip("skipping test; GOOS=linux https://issues.guix.gnu.org/issue/37425")
++ }
+ got := runTestProg(t, "testprog", "GCSys")
+ want := "OK\n"
+ if got != want {