summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gtk2-theme-paths.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-04-23 13:13:53 -0400
committerMark H Weaver <mhw@netris.org>2016-04-23 13:13:53 -0400
commite969b140a4382fd91514439a57749379cf00f86b (patch)
treec5c5adfc0c7c4cd0c367fa37203637e6d655544c /gnu/packages/patches/gtk2-theme-paths.patch
parent267061ba0bc6df0d61081b97d650d95acec8178a (diff)
Revert "Merge branch 'gnome-updates'"
This reverts commit 63655d459e28b09cd8d58743dae14b3460f6c9da, reversing changes made to 80627f51f0238b9450745f4e642172d059ca5bb5.
Diffstat (limited to 'gnu/packages/patches/gtk2-theme-paths.patch')
-rw-r--r--gnu/packages/patches/gtk2-theme-paths.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/patches/gtk2-theme-paths.patch b/gnu/packages/patches/gtk2-theme-paths.patch
deleted file mode 100644
index 6c1351e516..0000000000
--- a/gnu/packages/patches/gtk2-theme-paths.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: Jookia <166291@gmail.com>
-Subject: [PATCHv2] gtk: Patch GTK+ to look for themes in profiles.
-To: guix-devel@gnu.org
-Date: Sun, 13 Mar 2016 15:17:37 +1100
-Url: https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00492.html
-
-diff -Naur gtk+-2.24.28.new/gtk/gtkrc.c gtk+-2.24.28/gtk/gtkrc.c
---- gtk+-2.24.28.new/gtk/gtkrc.c 2016-03-13 10:31:14.413644362 +1100
-+++ gtk+-2.24.28/gtk/gtkrc.c 2016-03-13 12:51:34.723398423 +1100
-@@ -808,6 +808,8 @@
- gchar *path = NULL;
- const gchar *home_dir;
- gchar *subpath;
-+ const gchar * const *xdg_data_dirs;
-+ gint i;
-
- if (type)
- subpath = g_strconcat ("gtk-2.0-", type,
-@@ -830,6 +832,22 @@
- }
-
- if (!path)
-+ {
-+ xdg_data_dirs = g_get_system_data_dirs ();
-+ for (i = 0; xdg_data_dirs[i]; i++)
-+ {
-+ path = g_build_filename (xdg_data_dirs[i], "themes", name, subpath, NULL);
-+ if (g_file_test (path, G_FILE_TEST_EXISTS))
-+ break;
-+ else
-+ {
-+ g_free (path);
-+ path = NULL;
-+ }
-+ }
-+ }
-+
-+ if (!path)
- {
- gchar *theme_dir = gtk_rc_get_theme_dir ();
- path = g_build_filename (theme_dir, name, subpath, NULL);