summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-present-coding.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-02 09:48:37 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-02 09:50:25 +0200
commit26ecc2a780e3129aa3ebd7b130f1f8f17c57b4a4 (patch)
tree990423e75de5c0cb4717f2ffb0f6dc60cd492d4d /gnu/packages/patches/guile-present-coding.patch
parentddfddb0c45c1bf937663e15af641e6501b49d33f (diff)
gnu: Add missing patch for Guile-Present.
This patch should have been added in cdd383e. * gnu/packages/patches/guile-present-coding.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/guile-present-coding.patch')
-rw-r--r--gnu/packages/patches/guile-present-coding.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-present-coding.patch b/gnu/packages/patches/guile-present-coding.patch
new file mode 100644
index 0000000000..0655726158
--- /dev/null
+++ b/gnu/packages/patches/guile-present-coding.patch
@@ -0,0 +1,16 @@
+The tests/org-mode.scm tests expects 'jpl-outline-es' to be read as UTF-8.
+
+--- guile-present-0.3.0/tests/org-mode.scm 2014-09-23 22:29:51.426705753 +0200
++++ guile-present-0.3.0/tests/org-mode.scm 2014-09-23 22:30:09.634705548 +0200
+@@ -194,9 +194,10 @@
+ "(Just another hacker)"
+ "wingo@fluendo.com")
+ (p "Julien Moutte, CEO" "julien@fluendo.com")))
++ (with-fluids ((%default-port-encoding "UTF-8"))
+ (call-with-input-file
+ (in-vicinity *top-srcdir* "tests/jpl-outline-es")
+- org->presentation)))
++ org->presentation))))
+
+ (setlocale LC_ALL "")
+ (exit-with-summary (run-all-defined-test-cases))