summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-102-makeicecat.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2023-09-26 00:09:59 -0400
committerMark H Weaver <mhw@netris.org>2023-09-28 04:29:34 -0400
commitc4802226650b211680e08f15808e5e4d3835af24 (patch)
tree588f723243794ccbc3de7a4d18b7a93a10a569c9 /gnu/packages/patches/icecat-102-makeicecat.patch
parentf1823b5b6f39d343cedbda505cd2a74b33844206 (diff)
gnu: icecat: Update to 115.3.0-guix0-preview1 [security fixes].
Includes fixes for CVE-2023-5168, CVE-2023-5169, CVE-2023-5171, CVE-2023-5174, and CVE-2023-5176. * gnu/packages/gnuzilla.scm (icu4c-73-promise): New variable. (all-mozilla-locales, %icecat-base-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. (icecat-minimal)[inputs]: Use icu4c-73-promise. Remove nss. [native-inputs]: Use rust-cbindgen-0.24, llvm-15, clang-15, and node-lts. [arguments]<configure-flags>: Comment out "--with-system-nss". [description]: "IceCat 102" --> "IceCat 115". (%icecat-locales): Update. (all-mozilla-102-locales, %icecat-102-base-version) (%icecat-102-version, icecat-102-source): New variables bound to the old values, for use by icedove. (icedove-source): Ues 'icecat-102-source'. (make-l10n-package)[arguments]<phases>: Simplify reference to '#$locales, and thereby eliminate the unnecessary dependence on %icedove-locales by icecat-l10n, and similarly on %icecat-locales by icedove-l10n. [native-inputs]: Use node-lts. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new upstream. * gnu/packages/patches/icecat-102-makeicecat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/icecat-102-makeicecat.patch')
-rw-r--r--gnu/packages/patches/icecat-102-makeicecat.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-102-makeicecat.patch b/gnu/packages/patches/icecat-102-makeicecat.patch
new file mode 100644
index 0000000000..940ca36b6c
--- /dev/null
+++ b/gnu/packages/patches/icecat-102-makeicecat.patch
@@ -0,0 +1,51 @@
+Make some of the changes needed to the 'makeicecat' script, to allow it to run
+in a snippet without network access. After this patch is applied, some
+additional changes will be made using 'substitute*'.
+
+diff --git a/makeicecat b/makeicecat
+index bf2b7a6..bc3b19b 100755
+--- a/makeicecat
++++ b/makeicecat
+@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
+ # debug/shell options
+ readonly DEVEL=0
+ set -euo pipefail
+-(( DEVEL )) && set -x
++set -x
+
+
+ ###############################################################################
+@@ -455,7 +455,7 @@ configure_search()
+
+
+ # Process various JSON pre-configuration dumps.
+- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
++ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
+ }
+
+ configure_mobile()
+@@ -837,12 +837,12 @@ finalize_sourceball()
+ # entry point
+ ###############################################################################
+
+-validate_env || exit 1
+-prepare_env
+-fetch_source
+-verify_sources
+-extract_sources
+-fetch_l10n
++# validate_env || exit 1
++# prepare_env
++# fetch_source
++# verify_sources
++# extract_sources
++# fetch_l10n
+ apply_patches
+ configure
+ configure_search
+@@ -854,4 +854,4 @@ prepare_macos_packaging
+ configure_extensions
+ configure_onboarding
+ apply_bugfixes
+-finalize_sourceball
++# finalize_sourceball