summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-10-09 17:40:46 +0200
committerClément Lassieur <clement@lassieur.org>2023-10-09 18:11:07 +0200
commit7937c8827b8d23347a3159b4696335bd19fc17aa (patch)
tree0889a7d457506baeeb8d52ac2005d35c139fcb27 /gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch
parent87ffb3d3fbcc9273cb77f22e153ed31a70e2da11 (diff)
gnu: icu4c-73-promise: Fix broken test.
* gnu/local.mk (dist_patch_DATA): Add patch. * gnu/packages/gnuzilla.scm (icu4c-73-promise)[source]: Add patch. * gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch: New file.
Diffstat (limited to 'gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch')
-rw-r--r--gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch b/gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch
new file mode 100644
index 0000000000..5d149d8f28
--- /dev/null
+++ b/gnu/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch
@@ -0,0 +1,33 @@
+From b6b3e89231a623441940889b5badd90f74bdce2b Mon Sep 17 00:00:00 2001
+From: Frank Tang <ftang@chromium.org>
+Date: Mon, 18 Sep 2023 20:20:42 -0700
+Subject: [PATCH] ICU-22512 Fix broken TestHebrewCalendarInTemporalLeapYear
+
+Fix broken test mistakenly landed in
+https://github.com/unicode-org/icu/pull/2274
+
+Some important steps were missed in the last landing.
+---
+ icu4c/source/test/intltest/caltest.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/icu4c/source/test/intltest/caltest.cpp b/icu4c/source/test/intltest/caltest.cpp
+index 9d89f468eef0..18b96f231ba3 100644
+--- a/source/test/intltest/caltest.cpp
++++ b/source/test/intltest/caltest.cpp
+@@ -4028,6 +4028,7 @@ void CalendarTest::TestHebrewCalendarInTemporalLeapYear() {
+ for (gc.set(startYear, UCAL_JANUARY, 1);
+ gc.get(UCAL_YEAR, status) <= stopYear;
+ gc.add(UCAL_DATE, incrementDays, status)) {
++ cal->setTime(gc.getTime(status), status);
+ if (failure(status, "add/get/set/getTime/setTime incorrect")) return;
+
+ int32_t cal_year = cal->get(UCAL_EXTENDED_YEAR, status);
+@@ -4036,6 +4037,7 @@ void CalendarTest::TestHebrewCalendarInTemporalLeapYear() {
+ leapTest->set(UCAL_MONTH, 0);
+ leapTest->set(UCAL_DATE, 1);
+ // If 10 months after TISHRI is TAMUZ, then it is a leap year.
++ leapTest->add(UCAL_MONTH, 10, status);
+ hasLeapMonth = leapTest->get(UCAL_MONTH, status) == icu::HebrewCalendar::TAMUZ;
+ yearForHasLeapMonth = cal_year;
+ }