summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-03-27 07:01:37 -0400
committerMark H Weaver <mhw@netris.org>2021-03-27 19:49:14 -0400
commit2d3d7faf0a087c7836d71c92c8a67283c3d4dec5 (patch)
tree0c6cc88d537bb42640fe51e9fcb74deec10c6456 /gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
parentbfc69d5e7c45eac865e231643b58396580afb231 (diff)
gnu: imagemagick: Add more upstream fixes.
* gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch, gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch, gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/imagemagick.scm (source): Add patches.
Diffstat (limited to 'gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch')
-rw-r--r--gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch b/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
new file mode 100644
index 0000000000..f38a45b800
--- /dev/null
+++ b/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
@@ -0,0 +1,25 @@
+From 6a5d3575487487f2703383338bd17c8c25068f19 Mon Sep 17 00:00:00 2001
+From: Cristy <mikayla-grace@urban-warrior.org>
+Date: Thu, 25 Mar 2021 08:58:18 -0400
+Subject: [PATCH] eliminate compiler warning
+
+---
+ coders/thumbnail.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/coders/thumbnail.c b/coders/thumbnail.c
+index 3833341b0..1e2bfe8c2 100644
+--- a/coders/thumbnail.c
++++ b/coders/thumbnail.c
+@@ -199,7 +199,7 @@ static MagickBooleanType WriteTHUMBNAILImage(const ImageInfo *image_info,
+ q++;
+ }
+ if ((q > (GetStringInfoDatum(profile)+GetStringInfoLength(profile))) ||
+- (length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
++ ((ssize_t) length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
+ ThrowWriterException(CoderError,"ImageDoesNotHaveAThumbnail");
+ thumbnail_image=BlobToImage(image_info,q,length,&image->exception);
+ if (thumbnail_image == (Image *) NULL)
+--
+2.31.0
+