summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/isync-openssl3-fix.patch
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-04-27 17:14:47 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-24 15:04:01 +0200
commit6d0571215d661d21cac2150ca45906e77a79a5fb (patch)
treefe00313b959dcb409f8407a0dce4ea9104d25f25 /gnu/packages/patches/isync-openssl3-fix.patch
parentb5a85e31dd6fa3ed2582c79b8906abdc48ddd793 (diff)
gnu: isync: Add patch to improve openssl-3 compatibility.
* gnu/packages/patches/isync-openssl3-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/mail.scm (isync): Use patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/isync-openssl3-fix.patch')
-rw-r--r--gnu/packages/patches/isync-openssl3-fix.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/gnu/packages/patches/isync-openssl3-fix.patch b/gnu/packages/patches/isync-openssl3-fix.patch
new file mode 100644
index 0000000000..6a2363e972
--- /dev/null
+++ b/gnu/packages/patches/isync-openssl3-fix.patch
@@ -0,0 +1,81 @@
+Upstream status: Taken from master branch. Likely included in versions > 1.4.4
+
+Fixes issues with OpenSSL3. See related thread:
+https://sourceforge.net/p/isync/mailman/isync-devel/thread/Y2jnr8hESp1PUW+6@bulldog/
+
+From b6c36624f04cd388873785c0631df3f2f9ac4bf0 Mon Sep 17 00:00:00 2001
+From: Oswald Buddenhagen <ossi@users.sf.net>
+Date: Mon, 6 Jun 2022 11:55:37 +0200
+Subject: [PATCH] work around "unexpected EOF" error messages at end of SSL
+ connections
+
+gmail apparently doesn't send a close notification (SSL_shutdown())
+before closing the TCP socket.
+---
+ src/drv_imap.c | 7 +++++--
+ src/socket.c | 9 +++++++++
+ src/socket.h | 1 +
+ 3 files changed, 15 insertions(+), 2 deletions(-)
+
+diff --git a/src/drv_imap.c b/src/drv_imap.c
+index fb8d165..6286045 100644
+--- a/src/drv_imap.c
++++ b/src/drv_imap.c
+@@ -1620,6 +1620,7 @@ imap_socket_read( void *aux )
+ error( "IMAP error: unexpected BYE response: %s\n", cmd );
+ /* We just wait for the server to close the connection now. */
+ ctx->expectEOF = 1;
++ socket_expect_eof( &ctx->conn );
+ } else {
+ /* We still need to wait for the LOGOUT's tagged OK. */
+ }
+@@ -1882,10 +1883,12 @@ static void
+ imap_cleanup_p2( imap_store_t *ctx,
+ imap_cmd_t *cmd ATTR_UNUSED, int response )
+ {
+- if (response == RESP_NO)
++ if (response == RESP_NO) {
+ imap_cancel_store( &ctx->gen );
+- else if (response == RESP_OK)
++ } else if (response == RESP_OK) {
+ ctx->expectEOF = 1;
++ socket_expect_eof( &ctx->conn );
++ }
+ }
+
+ /******************* imap_open_store *******************/
+diff --git a/src/socket.c b/src/socket.c
+index ac3c847..892cece 100644
+--- a/src/socket.c
++++ b/src/socket.c
+@@ -810,6 +810,15 @@ socket_expect_activity( conn_t *conn, int expect )
+ conf_wakeup( &conn->fd_timeout, expect ? conn->conf->timeout : -1 );
+ }
+
++void
++socket_expect_eof( conn_t *sock )
++{
++#ifdef SSL_OP_IGNORE_UNEXPECTED_EOF // implies HAVE_LIBSSL
++ if (sock->ssl)
++ SSL_set_options( sock->ssl, SSL_OP_IGNORE_UNEXPECTED_EOF );
++#endif
++}
++
+ int
+ socket_read( conn_t *conn, char *buf, uint len )
+ {
+diff --git a/src/socket.h b/src/socket.h
+index 5b1edd0..af679aa 100644
+--- a/src/socket.h
++++ b/src/socket.h
+@@ -142,6 +142,7 @@ void socket_start_tls(conn_t *conn, void (*cb)( int ok, void *aux ) );
+ void socket_start_deflate( conn_t *conn );
+ void socket_close( conn_t *sock );
+ void socket_expect_activity( conn_t *sock, int expect );
++void socket_expect_eof( conn_t *sock );
+ int socket_read( conn_t *sock, char *buf, uint len ); /* never waits */
+ char *socket_read_line( conn_t *sock ); /* don't free return value; never waits */
+ typedef enum { KeepOwn = 0, GiveOwn } ownership_t;
+--
+2.39.2
+