summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kitty-fix-wayland-protocols.patch
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-30 18:34:40 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-30 18:34:40 -0400
commit62e917a0c6ae8f3ed9c16e288c9c6bccf13c3487 (patch)
tree5b3575a6f797a3efe4692fac54c95ee76429ba5b /gnu/packages/patches/kitty-fix-wayland-protocols.patch
parent5e9db8ad3f3ba91d94f98d5b4229d01ace3b3f5a (diff)
gnu: kitty: Update to 0.21.2.
There are newer versions of kitty but there are additional requirements. From v0.22.0 kitty requires additional Sphinx packages which use node to build themes. From v0.27.0 kitty additionally uses Go to build statically compiled, standalone binaries to use on servers. This will require more work to package, if possible at all currently (in the case of node and sphinx themes). * gnu/packages/patches/kitty-fix-wayland-protocols.patch: New file. * gnu/local.mk: Add it. * gnu/packages/terminals.scm (kitty): Update to 0.21.2. [source]: Use kitty-fix-wayland-protocols.patch. [native-inputs, inputs]: Remove labels. [phases]: Use gexps. Improve style. Use search-input-file. Remove trailing #t. {check}: Respect tests?.
Diffstat (limited to 'gnu/packages/patches/kitty-fix-wayland-protocols.patch')
-rw-r--r--gnu/packages/patches/kitty-fix-wayland-protocols.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/patches/kitty-fix-wayland-protocols.patch b/gnu/packages/patches/kitty-fix-wayland-protocols.patch
new file mode 100644
index 0000000000..6fcb38a360
--- /dev/null
+++ b/gnu/packages/patches/kitty-fix-wayland-protocols.patch
@@ -0,0 +1,37 @@
+See <https://github.com/kovidgoyal/kitty/issues/6422> for details.
+
+Modified with further fixes from <https://github.com/kovidgoyal/kitty/issues/6422#issuecomment-1622071032>.
+
+From 95d15648fa375bb131ff897f0db03b764dabaf65 Mon Sep 17 00:00:00 2001
+From: Kovid Goyal <kovid@kovidgoyal.net>
+Date: Wed, 5 Jul 2023 10:29:33 +0530
+Subject: [PATCH] Fix not building with wayland-protocols 1.32
+
+Fix #6422
+
+diff --git a/glfw/wl_platform.h b/glfw/wl_platform.h
+index f35b55e94..42c90b1fa 100644
+--- a/glfw/wl_platform.h
++++ b/glfw/wl_platform.h
+@@ -122,6 +122,7 @@ typedef enum WaylandWindowState {
+ TOPLEVEL_STATE_TILED_RIGHT = 32,
+ TOPLEVEL_STATE_TILED_TOP = 64,
+ TOPLEVEL_STATE_TILED_BOTTOM = 128,
++ TOPLEVEL_STATE_SUSPENDED = 256,
+ } WaylandWindowState;
+
+
+diff --git a/glfw/wl_window.c b/glfw/wl_window.c
+index f7e329609..23868154f 100644
+--- a/glfw/wl_window.c
++++ b/glfw/wl_window.c
+@@ -420,6 +420,9 @@ static void xdgToplevelHandleConfigure(void* data,
+ C(TOPLEVEL_STATE_TILED_RIGHT);
+ C(TOPLEVEL_STATE_TILED_TOP);
+ C(TOPLEVEL_STATE_TILED_BOTTOM);
++#ifdef XDG_TOPLEVEL_STATE_SUSPENDED_SINCE_VERSION
++ C(TOPLEVEL_STATE_SUSPENDED);
++ #endif
+ #undef C
+ }
+ }