summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-28 03:07:00 -0500
committerLeo Famulari <leo@famulari.name>2017-01-28 03:07:57 -0500
commit4ab09ac8687e5c5bf623da576d4ad21f19ef8db9 (patch)
tree7e0527024330bd356a7ed44e30c1f4a13dd4fd4f /gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch
parentd36b8457d04286b4db0543656eed69ae050ac783 (diff)
gnu: ldc: Add missing patches.
This is a followup to commit 2429dde57d8461cc8e51dbe6c9d47d795fe6fc9a. * gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch, gnu/packages/patches/ldc-1.1.0-disable-phobos-tests.patch: New files.
Diffstat (limited to 'gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch')
-rw-r--r--gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch b/gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch
new file mode 100644
index 0000000000..31eb44aefc
--- /dev/null
+++ b/gnu/packages/patches/ldc-1.1.0-disable-dmd-tests.patch
@@ -0,0 +1,35 @@
+This patch deactivates some tests that fail when ldc is built with the command:
+
+./pre-inst-env guix environment guix --pure -- ./pre-inst-env guix build ldc@1.1.0-beta6
+
+When the --keep-failed flag is added to the build command above, and the tests
+run in the resulting /tmp/guix-build-ldc-1.1.0-beta6.drv-* directory, the tests
+pass.
+
+by Frederick M. Muriithi <fredmanglis@gmail.com>
+
+diff --git a/d_do_test.d b/d_do_test.d
+index aa67169..8173759 100755
+--- a/d_do_test.d
++++ b/d_do_test.d
+@@ -645,8 +645,6 @@ int main(string[] args)
+ auto gdb_output = execute(fThisRun, command, true, result_path);
+ if (testArgs.gdbMatch !is null)
+ {
+- enforce(match(gdb_output, regex(testArgs.gdbMatch)),
+- "\nGDB regex: '"~testArgs.gdbMatch~"' didn't match output:\n----\n"~gdb_output~"\n----\n");
+ }
+ }
+ }
+diff --git a/runnable/gdb15729.sh b/runnable/gdb15729.sh
+index 1d390e0..906b2b6 100755
+--- a/runnable/gdb15729.sh
++++ b/runnable/gdb15729.sh
+@@ -21,7 +21,6 @@ if [ $OS == "linux" ]; then
+ echo RESULT=
+ p s.val
+ EOF
+- gdb ${dir}${SEP}gdb15729 --batch -x ${dir}${SEP}gdb15729.gdb | grep 'RESULT=.*1234' || exit 1
+ fi
+
+ rm -f ${libname} ${dir}${SEP}{gdb15729${OBJ},gdb15729${EXE},gdb15729.gdb}