summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mesa-opencl-all-targets.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-08-03 18:11:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-08-03 18:18:45 +0200
commit1685128e6e1147049feddee617a616ce7f3592c0 (patch)
tree5234e78d3034dfea96bb17e5a948e0d81a1082df /gnu/packages/patches/mesa-opencl-all-targets.patch
parent2b6bf23c607705abe88d6874303c2fea05bceb63 (diff)
gnu: mesa-opencl, mesa-opencl-icd: Build all the LLVM targets again.
Reported by John Kehayias <john.kehayias@protonmail.com> in <https://issues.guix.gnu.org/49794>. * gnu/packages/patches/mesa-opencl-all-targets.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gl.scm (mesa-opencl)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/mesa-opencl-all-targets.patch')
-rw-r--r--gnu/packages/patches/mesa-opencl-all-targets.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/mesa-opencl-all-targets.patch b/gnu/packages/patches/mesa-opencl-all-targets.patch
new file mode 100644
index 0000000000..99d4abcea4
--- /dev/null
+++ b/gnu/packages/patches/mesa-opencl-all-targets.patch
@@ -0,0 +1,25 @@
+This patch restores LLVM targets needed for OpenCL, *reverting* this
+upstream commit:
+
+ From 80817b6e344258ac9b955f824ebf9019a0fc1610 Mon Sep 17 00:00:00 2001
+ From: Jesse Natalie <jenatali@microsoft.com>
+ Date: Wed, 18 Nov 2020 18:30:30 -0800
+ Subject: [PATCH] meson: Adjust Clover's required LLVM modules
+
+diff --git a/meson.build b/meson.build
+index 6d1607c35a3..f828eb80faa 100644
+--- b/meson.build
++++ a/meson.build
+@@ -1479,10 +1479,9 @@
+ endif
+ if with_gallium_opencl
+ llvm_modules += [
+- 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
+- 'lto', 'option', 'objcarcopts', 'profiledata'
++ 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
++ 'lto', 'option', 'objcarcopts', 'profiledata',
+ ]
+- llvm_optional_modules += ['frontendopenmp']
+ endif
+ if with_microsoft_clc
+ llvm_modules += ['target', 'linker', 'irreader', 'option', 'libdriver']