summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mesa-timespec-test-32bit.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-04 20:12:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-04 20:12:41 +0100
commit33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f (patch)
tree79ee86a29266d0a32ec0d0aa790ee5904b1098b8 /gnu/packages/patches/mesa-timespec-test-32bit.patch
parent936aa05209402dd399869ffae188db5dd5f67d69 (diff)
parentd733a469d74f74734825f1ce777956fb4cac5534 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches/mesa-timespec-test-32bit.patch')
-rw-r--r--gnu/packages/patches/mesa-timespec-test-32bit.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/mesa-timespec-test-32bit.patch b/gnu/packages/patches/mesa-timespec-test-32bit.patch
new file mode 100644
index 0000000000..3e4890f3a4
--- /dev/null
+++ b/gnu/packages/patches/mesa-timespec-test-32bit.patch
@@ -0,0 +1,17 @@
+Fix a test failure on 32-bit systems.
+
+Taken from upstream:
+https://gitlab.freedesktop.org/mesa/mesa/commit/dd1dba80b9ee74ec8b90761285a8262e374bf8ef
+
+diff --git a/src/util/tests/timespec/timespec_test.cpp b/src/util/tests/timespec/timespec_test.cpp
+--- a/src/util/tests/timespec/timespec_test.cpp
++++ b/src/util/tests/timespec/timespec_test.cpp
+@@ -206,7 +206,7 @@ TEST(timespec_test, timespec_from_nsec)
+
+ timespec_from_nsec(&a, UINT64_MAX);
+ EXPECT_EQ(a.tv_nsec, UINT64_MAX % NSEC_PER_SEC);
+- EXPECT_EQ(a.tv_sec, UINT64_MAX / NSEC_PER_SEC);
++ EXPECT_EQ(a.tv_sec, (time_t)(UINT64_MAX / NSEC_PER_SEC));
+ }
+
+ TEST(timespec_test, timespec_from_usec)