summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openbios-aarch64-riscv64-support.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-08 16:10:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-09 15:10:16 +0200
commite22a6ed8f82eb094242a3c4c723f7ab7635a4976 (patch)
tree132e875e16ac4146ad8715ffb7233f5bb700b3f4 /gnu/packages/patches/openbios-aarch64-riscv64-support.patch
parent7b1dd1e9eae20d7df5f1bcde6f7bb4906fc7ef9f (diff)
gnu: make-openbios-package: Enable building from aarch64, riscv64.
* gnu/packages/firmware.scm (make-openbios-package)[source]: Add patch to correctly detect aarch64 and riscv64 build hosts. (openbios-qemu-ppc)[arguments]: Remove aarch64 workaround for #:system. * gnu/packages/patches/openbios-aarch64-riscv64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/openbios-aarch64-riscv64-support.patch')
-rw-r--r--gnu/packages/patches/openbios-aarch64-riscv64-support.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/openbios-aarch64-riscv64-support.patch b/gnu/packages/patches/openbios-aarch64-riscv64-support.patch
new file mode 100644
index 0000000000..25cf2499b8
--- /dev/null
+++ b/gnu/packages/patches/openbios-aarch64-riscv64-support.patch
@@ -0,0 +1,17 @@
+This was submitted upstream
+https://github.com/openbios/openbios/pull/12
+
+diff --git a/config/scripts/switch-arch b/config/scripts/switch-arch
+index b5acc6c..a96ef4b 100755
+--- a/config/scripts/switch-arch
++++ b/config/scripts/switch-arch
+@@ -38,7 +38,8 @@ longbits()
+ if test "$cpu" = "sparc64" -o "$cpu" = "ia64" \
+ -o "$cpu" = "amd64" -o "$cpu" = "x86_64" \
+ -o "$cpu" = "powerpc64" -o "$cpu" = "ppc64" \
+- -o "$cpu" = "ppc64le" -o "$cpu" = "alpha" ; then
++ -o "$cpu" = "ppc64le" -o "$cpu" = "alpha" \
++ -o "$cpu" = "aarch64" -o "$cpu" = "riscv64" ; then
+ echo 64
+ else
+ echo 32