summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/perl-module-pluggable-search.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-12 22:14:57 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-13 11:28:54 +0100
commit4de35074833742e45237464bb1727ce1a55f3336 (patch)
tree99681e951acc7044923e51aea8093781f83620bd /gnu/packages/patches/perl-module-pluggable-search.patch
parent4165fda29dcab7ae0a4cdb11d88dfe80a21c9c1d (diff)
gnu: perl: Update to 5.22.0.
* gnu/packages/perl.scm (perl)[source]: Update to 5.22.0. Remove "perl-module-pluggable-search.patch" since Module::Pluggable appears to be gone. [arguments] <configure-phase>: Adjust Cwd.pm file name. Replace -std=c89 with -std=gnu89. * gnu/packages/commencement.scm (perl-boot0): Add 'disable-pthreads' phase. * gnu/packages/patches/perl-no-sys-dirs.patch: Update. * gnu/packages/patches/perl-module-pluggable-search.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/perl-module-pluggable-search.patch')
-rw-r--r--gnu/packages/patches/perl-module-pluggable-search.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/patches/perl-module-pluggable-search.patch b/gnu/packages/patches/perl-module-pluggable-search.patch
deleted file mode 100644
index bb2a57f7e5..0000000000
--- a/gnu/packages/patches/perl-module-pluggable-search.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix core Perl module Module::Pluggable such that it can find plugins that live
-in symlinked directories.
-
-Patch borrowed/adapted from Nixpkgs.
-
---- perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
-+++ perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
-@@ -164,7 +164,7 @@
- my $sp = catdir($dir, (split /::/, $searchpath));
-
- # if it doesn't exist or it's not a dir then skip it
-- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
-+ next unless ( -e $sp );
-
- my @files = $self->find_files($sp);
-
-@@ -279,7 +279,7 @@
- (my $path = $File::Find::name) =~ s#^\\./##;
- push @files, $path;
- }
-- }, $search_path );
-+ }, "$search_path/." );
- }
- #chdir $cwd;
- return @files;