summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/picard-fix-id3-rename-test.patch
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-09-05 17:00:05 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-05 10:42:00 +0200
commit62cf60da7aa3d009c881456ca40a52714889e348 (patch)
tree0d68d60d802421f056cc8609511d09c3b6e259c7 /gnu/packages/patches/picard-fix-id3-rename-test.patch
parent4913e8ede09bf6f4efc27d3fb6e224cb87bbb9ee (diff)
gnu: picard: Update to 2.4.4.
* gnu/packages/music.scm (picard): Update to 2.4.4. [native-inputs]: Add python-dateutil. [source]: Add temporary patch to fix failing test due to missing "." in temporary filename. * gnu/packages/patches/picard-fix-id3-rename-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/picard-fix-id3-rename-test.patch')
-rw-r--r--gnu/packages/patches/picard-fix-id3-rename-test.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/picard-fix-id3-rename-test.patch b/gnu/packages/patches/picard-fix-id3-rename-test.patch
new file mode 100644
index 0000000000..3c4fa63c84
--- /dev/null
+++ b/gnu/packages/patches/picard-fix-id3-rename-test.patch
@@ -0,0 +1,11 @@
+Index: b/test/formats/test_id3.py
+===================================================================
+--- a/test/formats/test_id3.py
++++ b/test/formats/test_id3.py
+@@ -266,5 +266,5 @@
+ def test_rename_txxx_tags(self):
+ file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
+- filename = self.copy_file_tmp(file_path, 'mp3')
++ filename = self.copy_file_tmp(file_path, '.mp3')
+ raw_metadata = load_raw(filename)
+ self.assertIn('TXXX:Artists', raw_metadata)