summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-dateutil-pytest-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-16 00:10:07 +0200
committerMarius Bakke <marius@gnu.org>2022-10-16 00:10:07 +0200
commitc567a82a6975e70c8207a4aeed55a72b5121213c (patch)
tree8a6dfe8a78726933e4a1581a2c6ba4a84d59411f /gnu/packages/patches/python-dateutil-pytest-compat.patch
parent3a84b4ec4cec1d122cb454da9d4f6a747a51e49a (diff)
parent322917aeb8e672c21378fd371a5cff4a9f0c2520 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches/python-dateutil-pytest-compat.patch')
-rw-r--r--gnu/packages/patches/python-dateutil-pytest-compat.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-dateutil-pytest-compat.patch b/gnu/packages/patches/python-dateutil-pytest-compat.patch
new file mode 100644
index 0000000000..5cff57e94c
--- /dev/null
+++ b/gnu/packages/patches/python-dateutil-pytest-compat.patch
@@ -0,0 +1,43 @@
+Add compatibility with newer versions of pytest.
+
+Taken from upstream:
+
+ https://github.com/dateutil/dateutil/commit/2bdd63158b7f981fc6d70a869680451bdfd8d848
+
+diff --git a/dateutil/test/test_internals.py b/dateutil/test/test_internals.py
+index 53081314..b32e6723 100644
+--- a/dateutil/test/test_internals.py
++++ b/dateutil/test/test_internals.py
+@@ -9,6 +9,7 @@
+
+ import sys
+ import pytest
++import warnings
+
+ from dateutil.parser._parser import _ymd
+ from dateutil import tz
+@@ -65,18 +66,17 @@ def test_parser_parser_private_not_warns():
+ from dateutil.parser._parser import _timelex, _tzparser
+ from dateutil.parser._parser import _parsetz
+
+- with pytest.warns(None) as recorder:
++ with warnings.catch_warnings():
++ warnings.simplefilter("error")
+ _tzparser()
+- assert len(recorder) == 0
+
+- with pytest.warns(None) as recorder:
++ with warnings.catch_warnings():
++ warnings.simplefilter("error")
+ _timelex('2014-03-03')
+
+- assert len(recorder) == 0
+-
+- with pytest.warns(None) as recorder:
++ with warnings.catch_warnings():
++ warnings.simplefilter("error")
+ _parsetz('+05:00')
+- assert len(recorder) == 0
+
+
+ @pytest.mark.tzstr