summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qtwayland-gcc-11.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-10 19:43:05 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 00:21:11 +0200
commit88f976d1604e229c47ecfc16e0c95a36817d5043 (patch)
treec127406086e1abc6ec2ac345d36a247d501fc18e /gnu/packages/patches/qtwayland-gcc-11.patch
parentd8d4b81147df59542385a79191eb51e3568ae309 (diff)
gnu: qtwayland: Fix build with GCC 11.
* gnu/packages/patches/qtwayland-gcc-11.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/qt.scm (qtwayland)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches/qtwayland-gcc-11.patch')
-rw-r--r--gnu/packages/patches/qtwayland-gcc-11.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/qtwayland-gcc-11.patch b/gnu/packages/patches/qtwayland-gcc-11.patch
new file mode 100644
index 0000000000..06983ff2f3
--- /dev/null
+++ b/gnu/packages/patches/qtwayland-gcc-11.patch
@@ -0,0 +1,18 @@
+Add missing import for newer libstdc++.
+
+Taken from upstream:
+
+ https://github.com/qt/qtwayland/commit/1aa6ec2c778504d96543f6cdc2b9199a7b066fc1
+
+diff --git a/tests/auto/client/shared/corecompositor.cpp b/tests/auto/client/shared/corecompositor.cpp
+index 5c6c83baa..fa9b7662a 100644
+--- a/tests/auto/client/shared/corecompositor.cpp
++++ b/tests/auto/client/shared/corecompositor.cpp
+@@ -27,6 +27,7 @@
+ ****************************************************************************/
+
+ #include "corecompositor.h"
++#include <thread>
+
+ namespace MockCompositor {
+