summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/quilt-getopt-second-separator.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 07:48:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 11:00:13 +0200
commiteea75c435ab7d7b4f44b1aa4e900e2abf5ba430f (patch)
treef58f6ce0155716d5f5a71af59271a8fcd1e0df5b /gnu/packages/patches/quilt-getopt-second-separator.patch
parentd2f477ba82923301e4a7a65c7cc77d8c41a98b90 (diff)
gnu: quilt: Update to 0.66.
* gnu/packages/patchutils.scm (quilt): Update to 0.66. [source]: Remove all patches. * gnu/packages/patches/quilt-test-fix-regex.patch, gnu/packages/patches/quilt-getopt-nondigit-param.patch, gnu/packages/patches/quilt-getopt-second-separator.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/quilt-getopt-second-separator.patch')
-rw-r--r--gnu/packages/patches/quilt-getopt-second-separator.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/gnu/packages/patches/quilt-getopt-second-separator.patch b/gnu/packages/patches/quilt-getopt-second-separator.patch
deleted file mode 100644
index cde2c8d41c..0000000000
--- a/gnu/packages/patches/quilt-getopt-second-separator.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From: Jean Delvare <jdelvare@suse.de>
-Subject: compat/getopt: Handle a second separator
-
-getopt can be passed 2 '--' separators. The first one tells that
-getopt options are over and target program options start. The second
-one tells that the target program's options are over and following
-arguments should be treated as non-options even if they look like
-options.
-
-This second separator was not handled, causing the compatibility
-getopt script to treat the following arguments as options, eventually
-failing one way or another.
-
-Properly detect and handle the second separator. This fixes the first
-half of bug #54772:
-https://savannah.nongnu.org/bugs/index.php?54772
-
-Signed-off-by: Jean Delvare <jdelvare@suse.de>
----
- compat/getopt.in | 13 ++++++++++---
- 1 file changed, 10 insertions(+), 3 deletions(-)
-
---- quilt.orig/compat/getopt.in 2018-10-03 15:23:21.147620172 +0200
-+++ quilt/compat/getopt.in 2018-10-03 16:05:56.818667040 +0200
-@@ -8,12 +8,12 @@
-
- use strict;
-
--my $opts;
-+my $opts = '';
- my @words;
- my $found_sep = 0;
-
- foreach my $arg (@ARGV) {
-- if ($arg eq '--') {
-+ if (!$found_sep && $arg eq '--') {
- $found_sep = 1;
- }
- else {
-@@ -62,10 +62,17 @@ sub quote_word
- return "'$word'";
- }
-
-+# there can be a second separator, to inhibit processing following arguments
-+# as options
-+$found_sep = 0;
- foreach my $word (@words) {
-+ if ($word eq '--') {
-+ $found_sep = 1;
-+ next;
-+ }
-
- # allow '-' to be an option value
-- if (!$need_param && $word !~ /^-./) {
-+ if ($found_sep || (!$need_param && $word !~ /^-./)) {
- push @barewords, quote_word($word);
- next;
- }