summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/slim-config.patch
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-12-14 09:28:44 +0800
committerLudovic Courtès <ludo@gnu.org>2023-12-23 11:17:49 +0100
commit2c8cdb05502cacaf603da231796ccafa59671117 (patch)
treee5156e112a2d061ce589725ab6b1647ddf4de1a3 /gnu/packages/patches/slim-config.patch
parent3320c9704353cea29ae34662f3975bf6b58c87f9 (diff)
gnu: slim: Update to 1.4.0.
* gnu/packages/display-managers.scm (slim)[version]: Update to 1.4.0. [inputs]: Remove input label. [arguments]: Use gexp and remove fix-0-pointer-comparison. [home-pages]: Update to slim-fork's url. * gnu/packages/patches/slim-config.patch: Port to slim-1.4.0. * gnu/packages/patches/slim-display.patch: Port to slim-1.4.0. * gnu/packages/patches/slim-reset.patch: Deleted, no ablilty to port this patch for big change in v1.4.0. * gnu/packages/patches/slim-session.patch: Deleted. seem to work without this patch, further observation is needed. * gnu/packages/patches/slim-sigusr1.patch: Deleted, fixed in upstream. * gnu/local.mk: Remove slim-reset.patch, slim-session.patch, slim-sigur1.patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/slim-config.patch')
-rw-r--r--gnu/packages/patches/slim-config.patch43
1 files changed, 26 insertions, 17 deletions
diff --git a/gnu/packages/patches/slim-config.patch b/gnu/packages/patches/slim-config.patch
index 5e6135d75c..91eeb5f56c 100644
--- a/gnu/packages/patches/slim-config.patch
+++ b/gnu/packages/patches/slim-config.patch
@@ -1,27 +1,36 @@
Allow the configuration file and theme directory to be specified at run time.
+
Patch by Eelco Dolstra, from Nixpkgs.
+---
+ app.cpp | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
---- slim-1.3.6/app.cpp 2013-10-02 00:38:05.000000000 +0200
-+++ slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
-@@ -200,7 +200,9 @@
-
- /* Read configuration and theme */
- cfg = new Cfg;
-- cfg->readConf(CFGFILE);
-+ char *cfgfile = getenv("SLIM_CFGFILE");
-+ if (!cfgfile) cfgfile = CFGFILE;
-+ cfg->readConf(cfgfile);
+diff --git a/app.cpp b/app.cpp
+index 237477d..735df9c 100644
+--- a/app.cpp
++++ b/app.cpp
+@@ -285,7 +285,9 @@ void App::Run()
+ if ( cfg == 0 )
+ {
+ cfg = new Cfg;
+- cfg->readConf(CFGFILE);
++ const char* cfgfile = getenv("SLIM_CFGFILE");
++ if (!cfgfile) cfgfile = CFGFILE;
++ cfg->readConf(cfgfile);
+ }
string themebase = "";
string themefile = "";
- string themedir = "";
-@@ -208,7 +210,9 @@
- if (testing) {
- themeName = testtheme;
- } else {
+@@ -297,7 +299,9 @@ void App::Run()
+ }
+ else
+ {
- themebase = string(THEMESDIR) + "/";
-+ char *themesdir = getenv("SLIM_THEMESDIR");
++ const char* themesdir = getenv("SLIM_THEMESDIR");
+ if (!themesdir) themesdir = THEMESDIR;
+ themebase = string(themesdir) + "/";
themeName = cfg->getOption("current_theme");
string::size_type pos;
- if ((pos = themeName.find(",")) != string::npos) {
+ if ((pos = themeName.find(",")) != string::npos)
+--
+2.39.2
+