summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vtk-7-gcc-11-compat.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-29 22:06:02 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-31 18:01:52 +0800
commit1dc8cdaa72b62232a69de8424e488c910ee58d21 (patch)
treebfbbb8e1d31cc32465fcd01ebd8fefe3492e629b /gnu/packages/patches/vtk-7-gcc-11-compat.patch
parent6609f2f4a7ea4b86424f101b0502f6aa1c2c88d4 (diff)
gnu: vtk-7: Fix build.
* gnu/packages/patches/vtk-7-gcc-11-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (vtk-7)[source]: Add patch for gcc-11.
Diffstat (limited to 'gnu/packages/patches/vtk-7-gcc-11-compat.patch')
-rw-r--r--gnu/packages/patches/vtk-7-gcc-11-compat.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/vtk-7-gcc-11-compat.patch b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
new file mode 100644
index 0000000000..c7ab3af36e
--- /dev/null
+++ b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
@@ -0,0 +1,11 @@
+Description: GCC 11 now enforces that comparison objects be invocable as const.
+--- a/Rendering/Label/vtkLabelHierarchy.cxx
++++ b/Rendering/Label/vtkLabelHierarchy.cxx
+@@ -525,1 +525,1 @@
+- const vtkHierarchyNode & b)
++ const vtkHierarchyNode & b) const
+--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
++++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
+@@ -66,1 +66,1 @@
+- bool operator () ( const vtkIdType& a, const vtkIdType& b )
++ bool operator () ( const vtkIdType& a, const vtkIdType& b ) const