summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-01-26 15:16:54 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-26 15:16:54 +0100
commit0e480ca7b60428a62fc4681d7aca6c7c067add42 (patch)
tree146c8f2449e1f75a4fb0091b21e57528fe583461 /gnu/packages/patches
parent230de2e94b0041c5b6212449334f7c2d6254768a (diff)
gnu: guile: Update to 3.0.9.
* gnu/packages/guile.scm (guile-3.0-latest): Update to 3.0.9. * gnu/packages/package-management.scm (guix-for-cuirass): Remove. * gnu/packages/ci.scm (cuirass)[inputs]: Replace 'guix-for-cuirass' with 'guix'. * gnu/packages/patches/guile-continuation-stack-leak.patch, gnu/packages/patches/guile-cross-compilation.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-continuation-stack-leak.patch27
-rw-r--r--gnu/packages/patches/guile-cross-compilation.patch55
2 files changed, 0 insertions, 82 deletions
diff --git a/gnu/packages/patches/guile-continuation-stack-leak.patch b/gnu/packages/patches/guile-continuation-stack-leak.patch
deleted file mode 100644
index 0e57b7bb4e..0000000000
--- a/gnu/packages/patches/guile-continuation-stack-leak.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-This patch fixes a memory leak when capturing and resuming delimited
-continuations intensively, as is the case with the Shepherd 0.9+:
-
- https://issues.guix.gnu.org/59021
-
-diff --git a/libguile/vm.c b/libguile/vm.c
-index 6fd5c554f..516bae773 100644
---- a/libguile/vm.c
-+++ b/libguile/vm.c
-@@ -165,11 +165,13 @@ capture_stack (union scm_vm_stack_element *stack_top,
- scm_t_dynstack *dynstack, uint32_t flags)
- {
- struct scm_vm_cont *p;
-+ size_t stack_size;
-
-- p = scm_gc_malloc (sizeof (*p), "capture_vm_cont");
-- p->stack_size = stack_top - sp;
-- p->stack_bottom = scm_gc_malloc (p->stack_size * sizeof (*p->stack_bottom),
-- "capture_vm_cont");
-+ stack_size = stack_top - sp;
-+ p = scm_gc_malloc (sizeof (*p) + stack_size * sizeof (*p->stack_bottom),
-+ "capture_vm_cont");
-+ p->stack_size = stack_size;
-+ p->stack_bottom = (void *) ((char *) p + sizeof (*p));
- p->vra = vra;
- p->mra = mra;
- p->fp_offset = stack_top - fp;
diff --git a/gnu/packages/patches/guile-cross-compilation.patch b/gnu/packages/patches/guile-cross-compilation.patch
deleted file mode 100644
index a594cb9421..0000000000
--- a/gnu/packages/patches/guile-cross-compilation.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-When cross-compiling, get type sizes of the host system, not the build system.
-
-This is Guile commit 24b30130ca75653bdbacea84ce0443608379d630, which
-fixes <https://issues.guix.gnu.org/54198>, with one difference: it uses
-8 instead of SIZEOF_INTMAX_T, such that we do not need to modify
-'configure.ac' to check for the size of 'intmax_t' and to run 'autoreconf'
-(libguile/numbers.c expects SCM_SIZEOF_INTMAX_T = 8).
-
-diff --git a/libguile/gen-scmconfig.c b/libguile/gen-scmconfig.c
-index 01b14f14d..691ebd0af 100644
---- a/libguile/gen-scmconfig.c
-+++ b/libguile/gen-scmconfig.c
-@@ -1,4 +1,4 @@
--/* Copyright 2003-2013,2018,2020,2021
-+/* Copyright 2003-2013, 2018, 2020-2022
- Free Software Foundation, Inc.
-
- This file is part of Guile.
-@@ -238,21 +238,21 @@ main (int argc, char *argv[])
- pf ("\n");
- pf ("/* Standard types. */\n");
-
-- pf ("#define SCM_SIZEOF_CHAR %zu\n", sizeof (char));
-- pf ("#define SCM_SIZEOF_UNSIGNED_CHAR %zu\n", sizeof (unsigned char));
-- pf ("#define SCM_SIZEOF_SHORT %zu\n", sizeof (short));
-- pf ("#define SCM_SIZEOF_UNSIGNED_SHORT %zu\n", sizeof (unsigned short));
-- pf ("#define SCM_SIZEOF_LONG %zu\n", sizeof (long));
-- pf ("#define SCM_SIZEOF_UNSIGNED_LONG %zu\n", sizeof (unsigned long));
-- pf ("#define SCM_SIZEOF_INT %zu\n", sizeof (int));
-- pf ("#define SCM_SIZEOF_UNSIGNED_INT %zu\n", sizeof (unsigned int));
-- pf ("#define SCM_SIZEOF_SIZE_T %zu\n", sizeof (size_t));
-- pf ("#define SCM_SIZEOF_LONG_LONG %zu\n", sizeof (long long));
-- pf ("#define SCM_SIZEOF_UNSIGNED_LONG_LONG %zu\n", sizeof (unsigned long long));
-- pf ("#define SCM_SIZEOF_INTMAX %zu\n", sizeof (intmax_t));
-- pf ("#define SCM_SIZEOF_SCM_T_PTRDIFF %zu\n", sizeof (ptrdiff_t));
-- pf ("#define SCM_SIZEOF_INTPTR_T %zu\n", sizeof (intptr_t));
-- pf ("#define SCM_SIZEOF_UINTPTR_T %zu\n", sizeof (uintptr_t));
-+ pf ("#define SCM_SIZEOF_CHAR %d\n", SIZEOF_CHAR);
-+ pf ("#define SCM_SIZEOF_UNSIGNED_CHAR %d\n", SIZEOF_UNSIGNED_CHAR);
-+ pf ("#define SCM_SIZEOF_SHORT %d\n", SIZEOF_SHORT);
-+ pf ("#define SCM_SIZEOF_UNSIGNED_SHORT %d\n", SIZEOF_UNSIGNED_SHORT);
-+ pf ("#define SCM_SIZEOF_LONG %d\n", SIZEOF_LONG);
-+ pf ("#define SCM_SIZEOF_UNSIGNED_LONG %d\n", SIZEOF_UNSIGNED_LONG);
-+ pf ("#define SCM_SIZEOF_INT %d\n", SIZEOF_INT);
-+ pf ("#define SCM_SIZEOF_UNSIGNED_INT %d\n", SIZEOF_UNSIGNED_INT);
-+ pf ("#define SCM_SIZEOF_SIZE_T %d\n", SIZEOF_SIZE_T);
-+ pf ("#define SCM_SIZEOF_LONG_LONG %d\n", SIZEOF_LONG_LONG);
-+ pf ("#define SCM_SIZEOF_UNSIGNED_LONG_LONG %d\n", SIZEOF_UNSIGNED_LONG_LONG);
-+ pf ("#define SCM_SIZEOF_INTMAX %d\n", 8); /* like SIZEOF_INTMAX_T */
-+ pf ("#define SCM_SIZEOF_SCM_T_PTRDIFF %d\n", SIZEOF_PTRDIFF_T);
-+ pf ("#define SCM_SIZEOF_INTPTR_T %d\n", SIZEOF_INTPTR_T);
-+ pf ("#define SCM_SIZEOF_UINTPTR_T %d\n", SIZEOF_UINTPTR_T);
-
- pf ("\n");
- pf ("/* same as POSIX \"struct timespec\" -- always defined */\n");