summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-27 12:49:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-16 11:24:10 -0400
commit132ddca5a4fb6d789f98866b5bf85be95306c969 (patch)
tree23c74706927a4742aaaca6ac39f9961a1a3f1bdd /gnu/packages/patches
parent3309bb8ac2ed9f1ac904f83649f9f30c5c919e7f (diff)
gnu: elogind: Update to 252.9.
* gnu/packages/freedesktop.scm (elogind): Update to 252.9. [source]: Replace elogind-revert-polkit-detection.patch with elogind-fix-rpath.patch in patches. [configure-flags]: Add the dbussystemservicedir, dbussessionservicedir, dbussystemservicedir and dbus-interfaces-dir flags. [phases] <use-global-hook-directory> Update list of patched files. <adjust-tests> Update substitutions, and skip the copy_holes test. [native-inputs]: Add python-jinja2. [inputs]: Add util-linux:lib. * gnu/services/desktop.scm (elogind-dbus-service) <elogind-dbus-service-wrapper>: Add a symlink to elogind's share/dbus-1/system.d to expose D-Bus policy configurations. * gnu/tests/desktop.scm (run-elogind-test): Adjust expected result for the new "linger" value. * gnu/packages/patches/elogind-revert-polkit-detection.patch: Delete file. * gnu/packages/patches/elogind-fix-rpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Update. Series-to: 64938@debbugs.gnu.org Series-prefix: elogind-updates Series-version: 2 Series-changes: 2 - Fix elogind system test - Install D-Bus policy files in elogind-dbus-service-wrapper - Remove duplicate 'dbussystemservicedir' configure flag
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/elogind-fix-rpath.patch60
-rw-r--r--gnu/packages/patches/elogind-revert-polkit-detection.patch41
2 files changed, 60 insertions, 41 deletions
diff --git a/gnu/packages/patches/elogind-fix-rpath.patch b/gnu/packages/patches/elogind-fix-rpath.patch
new file mode 100644
index 0000000000..2a76cc467f
--- /dev/null
+++ b/gnu/packages/patches/elogind-fix-rpath.patch
@@ -0,0 +1,60 @@
+Retrieved from https://github.com/elogind/elogind/issues/258
+
+From: Mark Hindley <mark@hindley.org.uk>
+Date: Wed, 24 May 2023 10:39:41 +0100
+Subject: Fixup_executable_rpath
+
+./meson.build sets
+
+ install_rpath : rootlibexecdir
+
+however src/shared/meson.build sets
+
+libshared = shared_library(
+ [snip]
+ install_dir : rootpkglibdir
+ )
+---
+ meson.build | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 694a2fd..a575f69 100644
+--- a/meson.build
++++ b/meson.build
+@@ -2903,7 +2903,7 @@ executable('elogind',
+ dependencies : [threads,
+ libacl,
+ libudev],
+- install_rpath : rootlibexecdir,
++ install_rpath : rootpkglibdir,
+ install : true,
+ install_dir : rootlibexecdir)
+
+@@ -2913,7 +2913,7 @@ exe = executable('loginctl',
+ link_with : [libshared],
+ dependencies : [threads,
+ libudev],
+- install_rpath : rootlibexecdir,
++ install_rpath : rootpkglibdir,
+ install : true,
+ install_dir : rootbindir)
+ public_programs += [exe]
+@@ -2923,7 +2923,7 @@ exe = executable('elogind-inhibit',
+ include_directories : includes,
+ link_with : [libshared],
+ dependencies : [threads],
+- install_rpath : rootlibexecdir,
++ install_rpath : rootpkglibdir,
+ install : true,
+ install_dir : rootbindir)
+ public_programs += [exe]
+@@ -4283,7 +4283,7 @@ executable('elogind-uaccess-command',
+ libshared],
+ dependencies: [libacl,
+ libudev],
+- install_rpath : rootlibexecdir,
++ install_rpath : rootpkglibdir,
+ install : true,
+ install_dir : rootlibexecdir)
+ #endif // 0
diff --git a/gnu/packages/patches/elogind-revert-polkit-detection.patch b/gnu/packages/patches/elogind-revert-polkit-detection.patch
deleted file mode 100644
index 43dd1684b6..0000000000
--- a/gnu/packages/patches/elogind-revert-polkit-detection.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 715ce0a6459e418f92e74c7ce52df3244c18f383 Mon Sep 17 00:00:00 2001
-From: Sven Eden <sven.eden@prydeworx.com>
-Date: Mon, 8 Mar 2021 08:40:08 +0100
-Subject: [PATCH] Revert "Disable polkit support if libpolkit is not installed"
-
-This reverts commit 1194dec4f8f2d1b8bd14e1625f34418ecfce817e.
-
-Removing polkit support with -Dpolkit=auto when libpolkit is not
-installed, removes the whole interface. This makes it impossible to
-add polkit support as a runtime dependency.
-
-Bug: #167
-Closes: #206
-Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
----
- meson.build | 9 ---------
- 1 file changed, 9 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 2dd05db3c..f38551f55 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1157,15 +1157,6 @@ if want_polkit != 'false' and not skip_deps
- message('Old polkit detected, will install pkla files')
- install_polkit_pkla = true
- endif
--#if 1 /// Disable polkit completely if libpolkit is not there. See elogind issue #167
-- if not libpolkit.found()
-- if want_polkit != 'auto'
-- error('Polkit requested but libpolkit was not found.')
-- endif
-- install_polkit = false
-- want_polkit = false
-- endif
--#endif // 1
- endif
- conf.set10('ENABLE_POLKIT', install_polkit)
-
---
-2.33.1
-