summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-09 03:14:51 +0100
committerMarius Bakke <marius@gnu.org>2023-01-09 08:55:09 +0100
commit1efe7de0966afe1b96d7e8472d17a9c6142b5043 (patch)
tree8cda418514d0a09b1ddf7451d5e366d69c6e1d98 /gnu/packages/patches
parent2463e9f1fe10a1d7e02dff76f200da69cd3f24d1 (diff)
gnu: python-afdko: Fix failing tests.
* gnu/packages/patches/python-afdko-suppress-copyright-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/fontutils.scm (python-afdko)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-afdko-suppress-copyright-test.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-afdko-suppress-copyright-test.patch b/gnu/packages/patches/python-afdko-suppress-copyright-test.patch
new file mode 100644
index 0000000000..94cd73d5f7
--- /dev/null
+++ b/gnu/packages/patches/python-afdko-suppress-copyright-test.patch
@@ -0,0 +1,20 @@
+Supress copyright check in tests which can differ based on current year.
+
+ https://github.com/adobe-type-tools/afdko/issues/1589
+
+Adapted from upstream:
+
+ https://github.com/adobe-type-tools/afdko/commit/feebd77d9b6507a0b32f837535511be3c94d9c6f
+
+diff --git a/tests/tx_test.py b/tests/tx_test.py
+--- a/tests/tx_test.py
++++ b/tests/tx_test.py
+@@ -1246,7 +1246,7 @@ def test_ufo_fontinfo_parsing(file, msg, ret_code):
+ if (ret_code == 0):
+ expected_path = generate_ps_dump(expected_path)
+ output_path = generate_ps_dump(output_path)
+- assert differ([expected_path, output_path])
++ assert differ([expected_path, output_path, '-s'] + PFA_SKIP)
+ else:
+ arg = [TOOL, '-t1', '-f', ufo_input_path]
+ assert subprocess.call(arg) == 6