summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-14 22:19:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-14 22:21:41 -0400
commit261bc8f02885d89faed0deb682405a83d6c9d535 (patch)
tree87358429f8242e69148d4f0d0920fe0903f067b2 /gnu/packages/patches
parentd9b7982ba58fdea0934b60a81f507440a56c82ee (diff)
gnu: nautilus: Simplify how tracker tests are disabled.
* gnu/packages/gnome.scm (nautilus)[source]: Remove patches field. [phases]{disable-tracker-tests}: New phase. * gnu/packages/patches/nautilus-disable-tracker-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/nautilus-disable-tracker-tests.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/patches/nautilus-disable-tracker-tests.patch b/gnu/packages/patches/nautilus-disable-tracker-tests.patch
deleted file mode 100644
index bcc7b38f33..0000000000
--- a/gnu/packages/patches/nautilus-disable-tracker-tests.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-The tracker test hangs in the build container (see:
-https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
-
---- a/test/automated/displayless/meson.build 2022-09-10 00:52:50.348405729 -0400
-+++ b/test/automated/displayless/meson.build 2022-09-10 00:53:07.267907525 -0400
-@@ -34,41 +34,3 @@
- 'test-file-operations-trash-or-delete.c'
- ]]
- ]
--
--tracker_tests = [
-- ['test-nautilus-search-engine-tracker', [
-- 'test-nautilus-search-engine-tracker.c',
-- ]],
--]
--
--foreach t: tests
-- test(
-- t[0],
-- executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep),
-- env: [
-- test_env,
-- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
-- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
-- ],
-- timeout: 480
-- )
--endforeach
--
--
--
--# Tests that read and write from the Tracker index are run using 'tracker-sandbox'
--# script to use a temporary instance of tracker-miner-fs instead of the session one.
--foreach t: tracker_tests
-- test_exe = executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep)
-- test(
-- t[0],
-- tracker_sandbox,
-- args: ['--store-tmpdir', '--index-recursive-tmpdir', test_exe],
-- env: [
-- test_env,
-- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
-- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
-- ],
-- timeout: 480
-- )
--endforeach