summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2022-12-30 20:28:27 +0000
committerLudovic Courtès <ludo@gnu.org>2023-01-19 17:54:50 +0100
commit3846ceec4e5016394f8f9ae122e7c092ab0c0bf3 (patch)
tree80293648bc929d1e98db5af4144a6f478d573477 /gnu/packages/patches
parentf59df2f488061c68bb828470aef5c14811df4c4a (diff)
gnu: Add petri-foo.
* gnu/packages/music.scm (petri-foo): New public variable. * gnu/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch * gnu/local.mk (GNU_SYSTEM_MODULES): Add the new patch file. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch b/gnu/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch
new file mode 100644
index 0000000000..3e88487b07
--- /dev/null
+++ b/gnu/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch
@@ -0,0 +1,24 @@
+diff -Naur a/gui/bank-ops.c b/gui/bank-ops.c
+--- a/gui/bank-ops.c 2012-08-06 05:33:34.000000000 +0200
++++ b/gui/bank-ops.c 2012-08-07 17:57:28.580145691 +0200
+@@ -393,6 +393,8 @@
+ g_signal_connect_swapped(G_OBJECT(msg), "response",
+ G_CALLBACK(gtk_widget_destroy), msg);
+ gtk_widget_show (msg);
++
++ gtk_recent_manager_remove_item(recent_manager, filename, NULL);
+ }
+ else
+ {
+diff -Naur a/libpetrifui/dish_file.c b/libpetrifui/dish_file.c
+--- a/libpetrifui/dish_file.c 2012-08-06 05:33:34.000000000 +0200
++++ b/libpetrifui/dish_file.c 2012-08-07 17:56:09.063909801 +0200
+@@ -1440,7 +1440,7 @@
+
+ if (stat(path, &st) != 0)
+ {
+- msg_log(MSG_ERROR, "file '%s' does not exist\n");
++ msg_log(MSG_ERROR, "file '%s' does not exist\n", path);
+ return -1;
+ }
+