summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-27 15:08:25 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-28 21:13:36 +0200
commit4884ee6dd4b1694a4a502dd8058d6c61fa0c0199 (patch)
treefef3a27779d69b74481b1178fc02bd628a6d44da /gnu/packages/patches
parent8a8bd15bfa640e2a377f44ab1c59c5be0c525f86 (diff)
gnu: libexpected: Update to 1.1.0.
* gnu/packages/patches/libexpected-use-provided-catch2.patch: Add new patch. * gnu/packages/patches/libexpected-nofetch.patch: Remove unused patch. * gnu/local.mk (dist_patch_DATA): Register changes. * gnu/packages/cpp.scm (libexpected): Update to 1.1.0, and use new patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libexpected-nofetch.patch27
-rw-r--r--gnu/packages/patches/libexpected-use-provided-catch2.patch43
2 files changed, 43 insertions, 27 deletions
diff --git a/gnu/packages/patches/libexpected-nofetch.patch b/gnu/packages/patches/libexpected-nofetch.patch
deleted file mode 100644
index e1d104f6f4..0000000000
--- a/gnu/packages/patches/libexpected-nofetch.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Description: Disable FetchContent module
- No online operations are permitted during build package.
-Author: Nicholas Guriev <guriev-ns@ya.ru>
-Last-Update: Wed, 22 Jan 2020 21:51:33 +0300
-
-Modified by Brett Gilio <brettg@gnu.org> on Dec 5, 2020
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -4,16 +4,7 @@ project(tl-expected VERSION 1.0.0 LANGUAGES CXX)
-
- option(EXPECTED_ENABLE_TESTS "Enable tests." ON)
-
--include(FetchContent)
--FetchContent_Declare(
-- tl_cmake
-- GIT_REPOSITORY https://github.com/TartanLlama/tl-cmake.git
--)
--FetchContent_GetProperties(tl_cmake)
--if(NOT tl_cmake_POPULATED)
-- FetchContent_Populate(tl_cmake)
-- set(CMAKE_MODULE_PATH ${tl_cmake_SOURCE_DIR} ${CMAKE_MODULE_PATH})
--endif()
-+set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/tl-cmake ${CMAKE_MODULE_PATH})
- include(add-tl)
-
- tl_add_library(expected SOURCES
diff --git a/gnu/packages/patches/libexpected-use-provided-catch2.patch b/gnu/packages/patches/libexpected-use-provided-catch2.patch
new file mode 100644
index 0000000000..49d06e2d8f
--- /dev/null
+++ b/gnu/packages/patches/libexpected-use-provided-catch2.patch
@@ -0,0 +1,43 @@
+From 8f03ca270d1aa5dcafa945c941cf52ff14cb47da Mon Sep 17 00:00:00 2001
+Message-Id: <8f03ca270d1aa5dcafa945c941cf52ff14cb47da.1682600200.git.dev@jpoiret.xyz>
+From: Josselin Poiret <dev@jpoiret.xyz>
+Date: Thu, 27 Apr 2023 14:51:51 +0200
+Subject: [PATCH] Use provided catch2
+
+From: Josselin Poiret <dev@jpoiret.xyz>
+
+---
+ CMakeLists.txt | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ddab64e..2d5eac8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,7 +8,6 @@ project(tl-expected
+ include(CMakePackageConfigHelpers)
+ include(CMakeDependentOption)
+ include(GNUInstallDirs)
+-include(FetchContent)
+ include(CTest)
+
+ if (NOT DEFINED CMAKE_CXX_STANDARD)
+@@ -63,14 +62,7 @@ install(FILES
+ install(DIRECTORY "include/" TYPE INCLUDE)
+
+ if(EXPECTED_BUILD_TESTS)
+- set(CMAKE_POLICY_DEFAULT_CMP0077 NEW)
+- set(CATCH_INSTALL_HELPERS OFF)
+- set(CATCH_BUILD_TESTING OFF)
+- set(CATCH_INSTALL_DOCS OFF)
+- FetchContent_Declare(Catch2 URL
+- https://github.com/catchorg/Catch2/archive/v2.13.10.zip)
+- FetchContent_MakeAvailable(Catch2)
+-
++ find_package(Catch2 CONFIG)
+ file(GLOB test-sources CONFIGURE_DEPENDS tests/*.cpp)
+ list(FILTER test-sources EXCLUDE REGEX "tests/test.cpp")
+ add_executable(${PROJECT_NAME}-tests "${test-sources}")
+--
+2.39.2
+