summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-09-06 20:30:45 +0800
committerMarius Bakke <marius@gnu.org>2022-09-07 22:02:40 +0200
commit53c127c16defa1c0456dfc86df4cba5b267b0991 (patch)
treecc1f4cf353eed24ba45295c8941c7288693b1a8c /gnu/packages/patches
parentb7629ff995c49a3025b6edf3b240b48fe4b5b942 (diff)
gnu: python-apsw: Update to 3.39.2.1.
* gnu/packages/databases.scm (python-apsw): Update to 3.39.2.1. [source]: Change back to compressed release. * gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch: New file. * gnu/local.mk: Add patch. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch b/gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch
new file mode 100644
index 0000000000..cc233e3ccd
--- /dev/null
+++ b/gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch
@@ -0,0 +1,27 @@
+From 1111f902075169bd0d96cdd10607ef8499f0fed5 Mon Sep 17 00:00:00 2001
+From: Roger Binns <rogerb@rogerbinns.com>
+Date: Mon, 5 Sep 2022 07:12:25 -0700
+Subject: [PATCH] Deal with mismatched SQLITE_ENABLE_COLUMN_METADATA
+
+Address #363
+---
+ apsw/tests.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletion(-)
+
+diff --git a/apsw/tests.py b/apsw/tests.py
+index b4a94d3..256ead0 100644
+--- a/apsw/tests.py
++++ b/apsw/tests.py
+@@ -772,8 +772,8 @@ class APSW(unittest.TestCase):
+ c.execute("drop table foo; create table foo (%s)" % (", ".join(["[%s] %s" % (n, t) for n, t in cols]), ))
+ c.execute("insert into foo([x a space]) values(1)")
+ c.execute("create temp table two(fred banana); insert into two values(7); create temp view three as select fred as [a space] from two")
+- has_full=any(o=="ENABLE_COLUMN_METADATA" or o.startswith("ENABLE_COLUMN_METADATA=") for o in apsw.compile_options)
++ has_full=any(o=="ENABLE_COLUMN_METADATA" or o.startswith("ENABLE_COLUMN_METADATA=") for o in apsw.compile_options) if apsw.using_amalgamation else hasattr(c, "description_full")
+ for row in c.execute("select * from foo"):
+ self.assertEqual(cols, c.getdescription())
+ self.assertEqual(has_full, hasattr(c, "description_full"))
+
+base-commit: f628374c5857d940067ef26c9ea4e85a08a94f76
+--
+2.37.2