summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-19 05:02:00 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-19 05:02:00 +0800
commit597af70fd24eb85a85fa8c45008c9cfa241f4d0b (patch)
tree981c2f4cb803f5a3d33d50f132ecc114373c17a0 /gnu/packages/patches
parent0d70012efb3d19cf9ba955b5df493f193af0ca7e (diff)
parentf3f02dd9c8dce60db0abd84100000edc0b07b6c1 (diff)
Merge branch 'kde-updates'
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/akonadi-not-relocatable.patch6
-rw-r--r--gnu/packages/patches/grantlee-fix-i586-precision.patch40
-rw-r--r--gnu/packages/patches/kwayland-skip-flaky-test.patch13
3 files changed, 43 insertions, 16 deletions
diff --git a/gnu/packages/patches/akonadi-not-relocatable.patch b/gnu/packages/patches/akonadi-not-relocatable.patch
index bd4cbee79f..04c2a36b5f 100644
--- a/gnu/packages/patches/akonadi-not-relocatable.patch
+++ b/gnu/packages/patches/akonadi-not-relocatable.patch
@@ -22,10 +22,10 @@ index 4e8cc81..63161b7 100644
)
install(FILES
-diff --git a/KF5AkonadiConfig.cmake.in b/KF5AkonadiConfig.cmake.in
+diff --git a/KPimAkonadiConfig.cmake.in b/KPimAkonadiConfig.cmake.in
index bcf7320..1574319 100644
---- a/KF5AkonadiConfig.cmake.in
-+++ b/KF5AkonadiConfig.cmake.in
+--- a/KPimAkonadiConfig.cmake.in
++++ b/KPimAkonadiConfig.cmake.in
@@ -1,10 +1,10 @@
@PACKAGE_INIT@
diff --git a/gnu/packages/patches/grantlee-fix-i586-precision.patch b/gnu/packages/patches/grantlee-fix-i586-precision.patch
new file mode 100644
index 0000000000..f3d4384b5b
--- /dev/null
+++ b/gnu/packages/patches/grantlee-fix-i586-precision.patch
@@ -0,0 +1,40 @@
+From 13094b78a790786030a468453c2b3ead4c7fd9cf Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fabian@ritter-vogt.de>
+Date: Sun, 13 Nov 2022 14:01:21 +0100
+Subject: [PATCH] Fix formatting of some larger file sizes on 32bit x86
+
+With the x87 FPU available, GCC uses long double precision for some variables.
+Due to the function call passing a double, some comparisons break down.
+That resulted in "1.00 YB" being printed as "1000.00 ZB" instead.
+
+Fixes #85
+---
+ templates/lib/util.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/templates/lib/util.cpp b/templates/lib/util.cpp
+index 504674a7..a0381c59 100644
+--- a/templates/lib/util.cpp
++++ b/templates/lib/util.cpp
+@@ -23,6 +23,7 @@
+ #include "metaenumvariable_p.h"
+ #include "metatype.h"
+
++#include <cfloat>
+ #include <QtCore/QStringList>
+
+ QString Grantlee::unescapeStringLiteral(const QString &input)
+@@ -212,7 +213,13 @@ std::pair<qreal, QString> Grantlee::calcFileSize(qreal size, int unitSystem,
+ bool found = false;
+ int count = 0;
+ const qreal baseVal = (_unitSystem == 10) ? 1000.0F : 1024.0F;
++#if FLT_EVAL_METHOD == 2
++ // Avoid that this is treated as long double, as the increased
++ // precision breaks the comparison below.
++ volatile qreal current = 1.0F;
++#else
+ qreal current = 1.0F;
++#endif
+ int units = decimalUnits.size();
+ while (!found && (count < units)) {
+ current *= baseVal;
diff --git a/gnu/packages/patches/kwayland-skip-flaky-test.patch b/gnu/packages/patches/kwayland-skip-flaky-test.patch
deleted file mode 100644
index 592ab3cc77..0000000000
--- a/gnu/packages/patches/kwayland-skip-flaky-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-This test fails in the Guix CI for unknown and difficult to debug reasons.
-
-diff --git a/autotests/client/test_plasma_window_model.cpp b/autotests/client/test_plasma_window_model.cpp
---- a/autotests/client/test_plasma_window_model.cpp
-+++ b/autotests/client/test_plasma_window_model.cpp
-@@ -545,6 +545,7 @@ void PlasmaWindowModelTest::testPid()
-
- void PlasmaWindowModelTest::testVirtualDesktops()
- {
-+ QSKIP("This test fails on the Guix CI (FIXME)");
- auto model = m_pw->createWindowModel();
- QVERIFY(model);
- QSignalSpy rowInsertedSpy(model, &PlasmaWindowModel::rowsInserted);