summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-01-28 23:01:54 +0000
committerChristopher Baines <mail@cbaines.net>2024-02-13 11:04:47 +0000
commit5a8079e219e9052b036bc5d29be9692640d415dd (patch)
tree943a370dc2483eb340a49633b9f12cfb1a8e0898 /gnu/packages/patches
parent68bc23a5ba7d92d67744a24a24a3cfdd30bfe453 (diff)
gnu: tinydir: Update to 1.2.6.
* gnu/packages/c.scm (tinydir): Update to 1.2.6. * gnu/packages/patches/tinydir-fix-cbehave-test.patch: Adjust patch. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/tinydir-fix-cbehave-test.patch16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/patches/tinydir-fix-cbehave-test.patch b/gnu/packages/patches/tinydir-fix-cbehave-test.patch
index 84ecee12c2..1cad42c7a0 100644
--- a/gnu/packages/patches/tinydir-fix-cbehave-test.patch
+++ b/gnu/packages/patches/tinydir-fix-cbehave-test.patch
@@ -2,10 +2,22 @@ Make test work with upstream cbehave
(tinydir bundles a modified version)
diff --git a/tests/file_open_test.c b/tests/file_open_test.c
-index 3e659bc..9f6f88d 100644
+index 09b856e..92b13ca 100644
--- a/tests/file_open_test.c
+++ b/tests/file_open_test.c
-@@ -19,4 +19,7 @@ FEATURE(file_open, "File open")
+@@ -4,6 +4,11 @@
+ #include "cbehave.h"
+ #include "util.h"
+
++#define ASSERT(cond, ret) \
++if (!(cond)) {\
++ cbehave_feature_return(__FILE__, __LINE__, ret, _state); \
++ goto _feature_over; \
++}\
+
+ FEATURE(file_open, "File open")
+ SCENARIO("Open file in current directory")
+@@ -34,4 +39,7 @@ FEATURE(file_open, "File open")
SCENARIO_END
FEATURE_END