summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-05-13 08:43:29 -0700
committerChristopher Baines <mail@cbaines.net>2024-05-14 12:05:25 +0100
commit61140300c20609f540029e30b72b7bf466f259cd (patch)
tree35a3e5672507a0546b04eda0707ca2f6a9af06f2 /gnu/packages/patches
parent49ec9f4ba32657528e0924df402f6aa6e5509fd5 (diff)
gnu: xpra: Update to 6.0.
* gnu/packages/xorg.scm (xpra): Update to 6.0. [inputs]: Add xxhash. [native-inputs]: Change python-cython to python-cython-3. * gnu/packages/patches/xpra-6.0-install_libs.patch: New file. * gnu/packages/patches/xpra-6.0-systemd-run.patch: New file. * gnu/packages/patches/xpra-5.0-install_libs.patch: Removed. * gnu/packages/patches/xpra-5.0-systemd-run.patch: Removed. * gnu/local.mk (dist_patch_DATA): Update accordingly Change-Id: Ic8ec98296220aebabb3d94951e11a3c957a8fcbc Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xpra-6.0-install_libs.patch (renamed from gnu/packages/patches/xpra-5.0-install_libs.patch)30
-rw-r--r--gnu/packages/patches/xpra-6.0-systemd-run.patch (renamed from gnu/packages/patches/xpra-5.0-systemd-run.patch)12
2 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/patches/xpra-5.0-install_libs.patch b/gnu/packages/patches/xpra-6.0-install_libs.patch
index 4d40bf1f79..c608b519f4 100644
--- a/gnu/packages/patches/xpra-5.0-install_libs.patch
+++ b/gnu/packages/patches/xpra-6.0-install_libs.patch
@@ -4,39 +4,39 @@ This workaround for Gentoo interferes with our use of --no-compile during
the 'install stage.
diff --git a/setup.py b/setup.py
-index e254bf99c..90db55c3f 100755
+index 4f066fa8bf..14a9ed65ed 100755
--- a/setup.py
+++ b/setup.py
-@@ -663,8 +663,6 @@ if modules_ENABLED:
+@@ -760,8 +760,6 @@ if modules_ENABLED:
# Utility methods for building with Cython
-
- def add_cython_ext(*args, **kwargs):
+
+ def do_add_cython_ext(*args, **kwargs):
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
- return
if not cython_ENABLED:
raise ValueError(f"cannot build {args}: cython compilation is disabled")
if cython_tracing_ENABLED:
-@@ -1809,9 +1807,6 @@ else:
+@@ -1971,9 +1969,6 @@ else:
if root_prefix.endswith("/usr"):
- #ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
+ # ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
root_prefix = root_prefix[:-4]
- for x in sys.argv:
- if x.startswith("--root="):
- root_prefix = x[len("--root="):]
- print(f"install_data_override.run() root_prefix={root_prefix}")
+ print(f" root_prefix={root_prefix!r}")
build_xpra_conf(root_prefix)
-
-@@ -1955,13 +1950,6 @@ else:
+
+@@ -2116,13 +2111,6 @@ else:
if uinput_ENABLED:
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
-
-- #gentoo does weird things, calls --no-compile with build *and* install
-- #then expects to find the cython modules!? ie:
+
+- # gentoo does weird things, calls --no-compile with build *and* install
+- # then expects to find the cython modules!? ie:
- #> python2.7 setup.py build -b build-2.7 install --no-compile \
- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
-- #otherwise we use the flags to skip pkgconfig
-- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
+- # otherwise we use the flags to skip pkgconfig
+- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv): # noqa: E501
- pkgconfig = no_pkgconfig
-
+
if OSX and "py2app" in sys.argv:
import py2app #@UnresolvedImport
diff --git a/gnu/packages/patches/xpra-5.0-systemd-run.patch b/gnu/packages/patches/xpra-6.0-systemd-run.patch
index 437a8cc37f..2d60c29423 100644
--- a/gnu/packages/patches/xpra-5.0-systemd-run.patch
+++ b/gnu/packages/patches/xpra-6.0-systemd-run.patch
@@ -3,12 +3,12 @@ Distriction specific patch, not going upstream
Disable systemd-run if the command is not found.
diff --git a/xpra/scripts/main.py b/xpra/scripts/main.py
-index 3813331a5..46e2c83a6 100755
+index 1c5e8ddaad..084aabe792 100755
--- a/xpra/scripts/main.py
+++ b/xpra/scripts/main.py
-@@ -337,23 +337,26 @@ def use_systemd_run(s) -> bool:
+@@ -396,23 +396,26 @@ def use_systemd_run(s) -> bool:
cmd = ["systemd-run", "--quiet"]
- if getuid()!=0:
+ if getuid() != 0:
cmd += ["--user"]
- cmd += ["--scope", "--", "true"]
- proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
@@ -30,7 +30,7 @@ index 3813331a5..46e2c83a6 100755
+ r = proc.returncode
except TimeoutExpired: # pragma: no cover
r = None
-- return r==0
+- return r == 0
+ if r is None:
+ try:
+ proc.terminate()
@@ -43,6 +43,6 @@ index 3813331a5..46e2c83a6 100755
+ return r==0
+ except FileNotFoundError:
+ return False
-
+
+
def verify_gir():
- try: