summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-06-18 10:07:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-07 18:59:58 +0300
commit7cd4103e81a924de6678760c101b77dd9d31c865 (patch)
tree74009a0d925448584e71c5d53d12e407490e473a /gnu/packages/patches
parent81bbe95cd1864c58abde8896ed4eeb812e0c614d (diff)
gnu: yggdrasil: Update to 0.4.7.
* gnu/packages/networking.scm (yggdrasil): Update to 0.4.7. [arguments]: Use G-expressions. Set the package build name and version. Use go-1.20. [propagated-inputs]: Add go-golang-org-x-tools, go-github-com-olekukonko-tablewriter and go-github-com-mattn-go-colorable. * gnu/packages/patches/yggdrasil-extra-config.patch: Don't use deprecated "ioutil". Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/yggdrasil-extra-config.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/patches/yggdrasil-extra-config.patch b/gnu/packages/patches/yggdrasil-extra-config.patch
index bd4bea7b9f..7934e2b50f 100644
--- a/gnu/packages/patches/yggdrasil-extra-config.patch
+++ b/gnu/packages/patches/yggdrasil-extra-config.patch
@@ -33,7 +33,7 @@ index 58b8230..b9df98a 100644
panic(err)
}
+ if extraconffile != "" {
-+ extraconf, err = ioutil.ReadFile(extraconffile);
++ extraconf, err = os.ReadFile(extraconffile);
+ }
+ if err != nil {
+ panic(err)